7

I appear to have absolutely nothing but this ugly default font and a few common styles from the Palatino family.

I'm a newbie at LaTeX, so I hope you can bear with me. But I'm running Mac OS 10.7.5 with TeX Live. I'm using XSLT to compose my .tex file, and I can access Palatino by inserting \usepackage{palatino}.

The listing here suggests that Palatino is supposed to have its own styles for both small caps and old style numbering - and that LaTeX should support dozens more font families - but for the life of me I can't obtain any of these in my output PDF.

It would seem that I need to install a whole bunch of fonts, but now I'm just groping in the dark. Please help!

Example 1: Missing Small Caps in Palatino

My small-caps are simulated by scaling the full-caps glyphs; they're apparently not the separate font style listed for Palatino. This produces unbalanced text weight. (See http://theworldsgreatestbook.com/book-design-part-5/.)

This becomes obvious if I alternate between small-cap letter and explicitly scaled full-cap letter. They are 100% identical:

Small-cap letters are NOT supposed to be identical to scaled-down full-cap characters!

\documentclass[12pt]{book}
\usepackage{palatino}
\usepackage{fix-cm}
\def\switchcaps{\fontsize{8pt}{12pt}\selectfont}
\begin{document}
\fontsize{10pt}{12pt}\selectfont
\textsc{a}{\switchcaps{A}}\textsc{b}{\switchcaps{B}}\textsc{c}{\switchcaps{C}}\textsc{n}{\switchcaps{N}}\textsc{u}{\switchcaps{U}}
\end{document}

Log file: http://pastebin.com/43YHxqkg

Example 2: Missing Oldstyle Numbers in Palatino

When I use \oldstylenums, I get the proper style but in a default font, not in Palatino. I found this as a way to access Palatino's oldstyle numbering directly: [Utilizing oldstyle figures without resorting to \oldstylenums], but it doesn't work.

\documentclass[12pt]{book}
\usepackage{palatino}
\begin{document}
\renewcommand*\rmdefault{pplj}
Testing \textsc{Testing} 0123456789
\end{document}

Log file: http://pastebin.com/8ebHB1EE

Example 3: Missing Font Families (e.g. Day Roman)

Any other font I try is missing altogether. If it compiles at all it resorts to the default font. Here is an example following the "Usage" directions here: http://www.tug.dk/FontCatalogue/dayrom/

\documentclass[12pt]{book}
\renewcommand*\rmdefault{dayrom}
\usepackage[T1]{fontenc}
\begin{document}
Testing \textsc{Testing} \oldstylenums{0123456789}
\end{document}

Log file: http://pastebin.com/vj7hgdmf

  • 1
    Welcome to TeX.SX! Please add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. It would also be handy to edit in the .log file you get for the MWE. – Joseph Wright Aug 14 '13 at 19:09
  • I'm sorry, I should've done this before posting the question. As I did, it began to look more and more like a large "fix all my problems!" kind of question, combining three in one. What should I do? – Quartz Aug 14 '13 at 20:43
2

Problem 1

Use mathpazo rather than palatino, with the sc option:

\documentclass[12pt]{book}
\usepackage[sc]{mathpazo}
\def\switchcaps{\fontsize{8pt}{12pt}\selectfont}
\begin{document}
\fontsize{10pt}{12pt}\selectfont
\textsc{a}{\switchcaps{A}}%
\textsc{b}{\switchcaps{B}}%
\textsc{c}{\switchcaps{C}}%
\textsc{n}{\switchcaps{N}}%
\textsc{u}{\switchcaps{U}}
\end{document}

enter image description here

Problem 2

Use mathpazo rather than palatino, with the option osf (that implies sc)

\documentclass[12pt]{book}
\usepackage[osf]{mathpazo}
\begin{document}
\renewcommand*\rmdefault{pplj}
Testing \textsc{Testing} 0123456789
\end{document}

enter image description here

Problem 3

The dayroman font is not available in TeX Live (hence MacTeX) for licensing reasons. You must install it with the getnonfreefonts-sys utility.

Note that the font lacks small caps old style figures are the default.

\documentclass[12pt]{book}
\renewcommand*\rmdefault{dayrom}
\usepackage[T1]{fontenc}
\begin{document}
Testing \textsc{Testing} 0123456789
\end{document}

enter image description here

The log file will have a warning

LaTeX Font Warning: Font shape `T1/dayrom/m/sc' undefined
(Font)              using `T1/dayrom/m/n' instead on input line 5.
  • Problem 1: Error log, missfont.log. Problem 2: Error log, missfont.log. – Quartz Dec 10 '13 at 3:41
  • For problem 3, I didn't get past installing the Day Roman font... I followed the instructions you linked to, and getnonfreefonts gave me an error. Here is the log. Am I doing something wrong? :( – Quartz Dec 10 '13 at 3:58
  • @Quartz You should be using getnonfreefonts-sys. – egreg Dec 10 '13 at 7:51
  • Same error. Log – Quartz Dec 12 '13 at 15:12
0

I finally satisfied my need by giving up on the default font system altogether and finding a way around it. It's a compromise, so if someone comes later who can actually fix my installation (or educate me on what I was doing wrong?) I'm willing to pick their answer instead.

It all started with settling for a font which I could obtain in a TTF or OTF file with the requisite variations (small caps, oldstyle & lining figures) definitely built in. So far I found this, by the League of Moveable Type.

Yes, just one solitary option so far. It's a sacrifice of variety for quality. I'm doing it.

A quick search revealed xelatex as an alternative to pdflatex in my TexLive installation, which can follow a path to the file. Hook it up, and viola:

\documentclass[12pt]{book}
\usepackage{fontspec}
\setmainfont[Numbers=Lining]{font.otf}
\newfontfamily{\oldstylenums}{font.otf}
\usepackage{fix-cm}
\def\switchcaps{\fontsize{6.4pt}{12pt}\selectfont}
\begin{document}
\fontsize{10pt}{12pt}\selectfont
\textsc{a}{\switchcaps{A}}\textsc{b}{\switchcaps{B}}\textsc{c}{\switchcaps{C}}\textsc{n}{\switchcaps{N}}\textsc{u}{\switchcaps{U}}

Testing \textsc{Testing} 0123456789 \oldstylenums{0123456789}
\end{document}

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.