I am using TeXworks version 0.4.5 with MiKTeX 2.9 64-bit on Windows 7. When I try to typeset the code

Blah blah \cite{grimm}

Latex warns that there were undefined references, and in the pdf there is a bolded question mark instead of the reference, and the references section at the end is empty. When I run BibTeX by itself I get the error "I couldn't open the database file diss.bib"

diss.bib looks like this

  title= "A theorem about random fields"

Things I have tried which haven't worked:

  • Saving the .bib file in the same place as the .tex file
  • Savind the file in a TDS-compliant root directory C:\tex-biblio\bibtex\bib\mybiblios\diss.bib and adding this as a root directory in MiKTeX (it accepts it as a new root directory, but BibTeX still can't find the .bib file)
  • Creating a BIBINPUTS environmental variable and adding a path to where the .bib file is saved
  • Writing a path to the .bib file when defining which bibliography to use: \bibliography{C:/Users/Sacrebleurgh/Documents/Latex/diss} - i've also tried diss.bib.
  • I originally downloaded MiKTeX with LyX so I tried uninstalling them both and then installing MiKTeX by itself, but the problem persisted.

Any suggestion as to what might be wrong or other things to try would be greatly appreciated.

EDIT: the bibtex log is

This is BibTeX, Version 0.99d (MiKTeX 2.9 64-bit)
The top-level auxiliary file: testdoc.aux
The style file: plain.bst
I couldn't open database file diss.bib
---line 4 of file testdoc.aux
 : \bibdata{diss
 :              }
I'm skipping whatever remains of this command
I found no database files---while reading file testdoc.aux
Warning--I didn't find a database entry for "grimm"
(There were 2 error messages)
  • 1
    If I save those files to dis111.tex and diss.bib and go pdflatex dis111; bibtex dis111; pdflatex dis111; pdflatex dis111 the citation resolves and [1] is listed as A theorem about random fields with just a warning from bibtex as it can not sort the database as no author or key field. Aug 15, 2013 at 13:26
  • Thanks for your reply. I tried doing it from the command line inside the folder with the .tex and .bib files saved in but bibtex still couldn't find the .bib file. Aug 15, 2013 at 13:58
  • 1
    can you post the exact bibtex log Aug 15, 2013 at 14:01
  • 1
    the aux file should have \bibdata{diss} (no space after diss) Aug 15, 2013 at 14:12
  • 1
    Did you check if there is some invisible utf8 in the file name or the document? Aug 15, 2013 at 18:25

2 Answers 2


I finally managed to solve this problem on my own:

Jabref was encoding the bib-files in 16bit and Bibtex was expecting 8bit-code. After switching to 8bit in the Jabref-options the problem solved itself.

Thank you so much for all your efforts.


I was getting the same error message, with TexLive when moving from Windows to Ubuntu, so in case anyone else runs into this...

The file I had been using was called test.BIB, which wasn't being recognized by bibtex. Copy/pasted the contents to a new file called test1.bib and worked fine.

  • 5
    Unix-derived operating system have filenames that are case-sensitive (unlike Windows). Hence, test.BIB and test.bib are not the same. BibTeX will look for the file with exension .bib, not .BIB.
    – Mico
    Apr 9, 2014 at 20:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .