2

I recently installed Ubuntu 13.04 and tried to recompile a pstricks document I had previously created on an older version of Ubuntu. However all the images came out wrong and consist of all the text contained in the image overlayed at a single position within the image. Lines and shapes are not rendered at all.

Trying the basic pstricks example also does not render correctly in the dvi.

\documentclass{article}
\usepackage{pstricks}
\begin{document}
\begin{figure}
\begin{pspicture}(4,5)
\psframe(0.7,2)(3.3,3)
\rput(2,2.5){First Example}
\end{pspicture}
\end{figure}
\end{document}

It just prints the text without the surrounding frame. I've tried uninstalling texlive and pstricks and reinstalling everything (using apt-get) to no avail. I would appreciate any pointers as to how I can go about tracking down the issue.

Edit: Solved thanks to JosephWright's answer. At first I was compiling using the quickbuild option in texmaker with

latex -> view dvi 

which gave the garbled output. I then tried

latex -> dvips -> view ps

That just hangs indefinitely so I started compiling using just latex and checking the dvi.

Using

latex -> dvips -> ps2pdf 

works perfectly.

  • 1
    run the document with xelatex. Then you'll get a PDF output – user2478 Aug 16 '13 at 14:29
3

In general, DVI viewers can't render PostScript (some do include code to do the conversion on-the-fly). Conversion to PostScript (or through to PDF) format is usually the best way to check on the correctness of the output: for me all is fine with the demo (TeX Live 2013).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.