0

I'm trying to get a Beamer-Presentation in Latex. My Windows is 7 PC. I'm using MiKTeX 2.9. At first, when I open the .tex file in the editor I don't get a preview at all. It is appeared this window: Package installation the required file tex\latex\ms\everyshi.sty is missing

I downloaded "ms file" from http://ctan.org/tex-archive/macros/latex/contrib/ms .But, it doesn't work.

5
  • You need to install the package. The easiest way to do that is from the Start Menu->All Programs->MikTEX 2.9->Maintenance (Admin)->Package Manager (Admin) and search for the package you need. You can also open the Settings (Admin) shortcut from that same folder, and choose "Ask me every time" to the option "Install packages automatically". Then, when you compile the document, MikTEX should ask you if you want to install missing packages. Note: You cannot answer "Yes" to that option because MikTEX won't have admin priviliges when it tries to install the new package, and it won't work. – darthbith Aug 16 '13 at 13:13
  • @darthbith -- that sounds like an answer. please enter it as one. – barbara beeton Aug 16 '13 at 13:21
  • @darthbith: Miktex can install packages for the current user (also on-the-fly). You don't need admin rights, you only need to use the user versions of the tools. – Ulrike Fischer Aug 16 '13 at 13:28
  • @UlrikeFischer Does that mean choosing to install MikTEX in a user folder (like APPDATA or something)? If so, it will then obviously depend on where the user has installed MikTEX whether or not it needs admin permissions to install a package... – darthbith Aug 16 '13 at 14:59
  • @darthbith: No, when you have a multiuser installation every user can install packages in his account. Miktex creates a dedicated "UserInstall" root in the user profile for such installations and it is used by the Package Manager (without "(admin)"). Naturally only the user will see this packages, if another user account needs them too, he will have to install them too - or the admin will have to install for all. – Ulrike Fischer Aug 16 '13 at 15:20
1

You need to install the package. The easiest way to do that is from the Start Menu->All Programs->MikTEX 2.9->Maintenance (Admin)->Package Manager (Admin) and search for the package you need. You can also open the Settings (Admin) shortcut from that same folder, and choose "Ask me every time" to the option "Install packages automatically". Then, when you compile the document, MikTEX should ask you if you want to install missing packages. Note: You cannot answer "Yes" to that option because MikTEX won't have admin priviliges when it tries to install the new package, and it won't work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.