36

I have a .bib file created automatically with jabRef. When I use it in my thesis some of the author names are full and some only initial letter. Why? How can I have only inital for all?

Here is a MWE:

    \documentclass[a4paper,11pt,titlepage,twoside,openright]{book}
    \usepackage[utf8]{inputenc}
    \usepackage[italian,english]{babel}
    \usepackage[T1]{fontenc}
    \usepackage{csquotes}
    \usepackage{hyperref}
    \usepackage[style=numeric-comp,sorting=none,sortcites=true,doi=false,url=false, hyperref]{biblatex}

    \renewbibmacro{in:}{ %eliminates the 'in' in the biblio
    \ifentrytype{article}{}{%
    \printtext{\bibstring{in}\intitlepunct}}}

    \renewcommand*{\bibfont}{\small}

    \bibliography{bib_tesi}
    \AtEveryBibitem{%
    \clearfield{month}%
    \clearlist{language}%
    }

    \begin{document}

    \backmatter
    \begingroup
    \phantomsection
    \printbibliography
    \addcontentsline{toc}{chapter}{Bibliography}      
    \endgroup

    \end{document}
2
  • 8
    use firstinits=true when loading biblatex – karlkoeller Aug 18 '13 at 13:51
  • Was it so easy? it works! But I found other people using more complex ways... Thank you!!! – Stefano_g Aug 18 '13 at 14:06
49

To achieve what you want it suffices to load biblatex package with the option giveninits=true.

So in your document put

\usepackage[%
    style=numeric-comp,sorting=none,
    sortcites=true,doi=false,url=false,
    giveninits=true,hyperref]{biblatex}

Older versions of biblatex used firstinits rather than giveninits: the previous option still works at present but is deprecated.

1
  • 1
    is there a way to force initials on some references but not all? – Zach Smith Feb 14 '18 at 16:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.