I have been using TexMaker for one year and everything was pretty smooth until recently. Right now as long as there is a figure in the pdf, when I compile the file (successfully) and scroll down to that figure, the whole program freezes and never responds again. However, the pdf files themselves are fine and can be opened using any pdf reader. It happens to any manuscript with any type of figure, despite the fact that I could open all of them before. When there is no figure, or there is a figure at the end of the paper and I don't scroll to the figure, everything seems to be fine. I tried deleting the software (and the preference file) and installed a newer version, but it did not work.

I didn't do anything serious(that I can remember) to my system before this problem came up. I am using a Windows 8 Pro (upgraded from Win 7 a long time ago), with Adobe Reader 11. Does anyone know where the problem is? Thanks a lot!

  • 1
    Welcome to TeX.SX! You can have a look on our our starter page to familiarize yourself further with our format. Aug 21, 2013 at 8:39
  • 2
    Why don't you post a report on the official Texmaker issue tracker with your pdf and source files?
    – user27168
    Aug 21, 2013 at 12:59
  • Good suggestion. I'll post a report to them. But actually I don't think it is the problem for any single source and/or pdf file. I simply could not open any pdf file with figure in the built-in viewer right now.
    – Javy
    Aug 22, 2013 at 3:08

2 Answers 2


I've tried on windows 8 and there is no trouble :

enter image description here

  • Is there some way to have a record of TeXmaker actions.log for better diagnosis of ambiguous crashes to support both User and Author with evidence: may be in the lines of program execution trace Aug 22, 2013 at 15:59
  • You're absolutely right that Windows 8 could work perfectly fine. Actually I have been using Windows 8 for about half a year until the internal pdf-viewer occurred. That's why I suspect if it is due to some changes made to my OS environment (but I can barely remember any).
    – Javy
    Aug 23, 2013 at 17:07

I had the same problem with .eps and .pdf graphics and upgraded to the latest TexMaker (4.2 from 4.1 I think) which has fixed the problem. Oh, and I am running Windows 8.1 and Foxit PDF viewer (not sure if that last detail is important however).


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .