Although a Newbie, I have been using XeteX, bidi and BiblateX with great success in Urdu. I have alphabetical footnotes with most of the secondary sources in the endnotes. The endnotes and bibliography are in English, whereas the rest is in Urdu. Modifying headers and footers works great as well.

However, I would like to get rid of the Chapter Heading including the number above the Urdu title نوٹس. And I would like to center the subheadings. Modifying with enoteheadings doesn't seem to do the trick (problem with memoir + XeteX? Same with \titlesec. Could there be a compatibility issue between memoir and \endnotes resp. \titlesec?

Any ideas?

My minimal example:

% !TEX TS-program = xelatex

\usepackage[a5paper, left=.915in,right=.915in,top=1.651cm,bottom=1.524cm]   {geometry}

\usepackage{fontspec}% font selecting commands
\usepackage{xunicode}% unicode character macros

\defaultfontfeatures{Scale=MatchLowercase, Mapping=tex-text}
\setmainfont[Script=Arabic,Scale=1.3, WordSpace=1]{Jameel Noori Nastaleeq}
\newfontfamily\latin[Ligatures=TeX]{Linux Libertine O}
\newfontfamily\greek[Script=Greek]{Linux Libertine O}


\posttitle{\par\end{center}\vskip 6em}

%%% ToC (table of contents)APPEARANCE
\maxtocdepth{subsection} % include subsections
\renewcommand{\cftchapterfont}{}     % no bold!
\renewcommand*{\contentsname}{فہرست ِ مضامین}





\renewcommand*{\pagenotesubhead}[3]{\section*{#2  #1}}


\renewcommand*{\notenuminnotes}[1]{\latin #1.\space}
\renewcommand*{\prenoteinnotes}{\par\noindent\hangindent 2em}

\usepackage[backend=biber,autocite=footnote,sortcites=true,   style=authortitle-icomp,block=space,notetype=endonly,firstinits=true,language=british]{biblatex}


آپ ایمان کی دوڑ میں اچھی ترقی کر رہے تھے! تو پھر کس نے آپ کو سچائی کی پیروی کرنے سے روک لیا؟ 
\footnote{گلتیوں 5:\! 7}

زہر کے پیالے کو ہونٹوں تک اُٹھا کر اُس نے بلاجھجک اور زندہ دلی سے زہر کو پی لیا۔ یہاں تک ہم جو ساتھ تھے زیادہ تر سنبھلے ہوئے تھے۔ لیکن جب دیکھا
کہ وہ زہر کو پی کر تہہ تک پہنچ گیا ہے تو ہم اپنے آنسوؤں کو روک نہ سکے۔ میں بھی  اپنے آپ پر قابو نہ پا سکا بلکہ زار و قطار رونے لگا۔

%%print endnote
%%print endnote


The bibliography.bib file linked to this:

  author = {Robert Murray},
  title = {The Exhortation to Candidates for Ascetical Vows at Baptism in the Ancient Syrian Church},
  journal = {New Testament Studies},
  year = {1974–75},
  volume = {21},
  pages = {58–79},
  timestamp = {2013.03.13}

  title = {Antioch and Syrian Christianity},
  author = {Najim, Michel},
  editor = {Frazer, Terry},
  subtitle = {A Chalcedonian Perspective on a Spiritual Heritage},
  timestamp = {2011.08.29},
  url = {www.stnicholasla.com/frmichel/antiochandsyriacchristianity.pdf},
  urldate = {2011-08-31}

The font Jameel Noori Nastaleeq is found here http://urdu.ca/1 (Other Operating Systems).

endnotes image

1 Answer 1


Adding the following code after \renewcommand*{\notesname}{نوٹس} did the trick:


There was an issue involving changing the setting from RL to LR in the bibliography. This was fixed by replacing \printbibliography with

\setmainfont{Linux Libertine O}

This is not a perfectly satisfactory solution. What is not evident in this minimal example is that a pagestyle (in my case headings) involving headers can cause problems; in my case, I had to define the pagestyle again before printing the endnotes thus:


Otherwise the headings of the preceding chapter carried on into the endnote headings.

This again meant that I had to define the pagestyle of the bibliography before printing it as well:


This works fine, but I'm curious to know if there is a cleaner solution.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .