I am just starting with LaTeX so I am sure I have made a bunch of silly mistake on the way. But as of yesterday I am stuck with no solution. So here is a bit of background:

Win7, installed MikeTex (with auto-installed package setting) and using TexMaker for editing, and installed JabRef for creating bib-files.

So I have created a .bib file with several entries, and put it in the same directory as my .tex file. And yet when I try to generate the reference list by invoking /cite{...}, the result list it is empty, and there was warning of:

LaTeX Warning: Citation `Duffie2001' on page 1 undefined on input line 8.
No file foo.bbl.

Here is the test .tex file:



This is my first document with a bibliography generated by Bib\TeX. Now I cite an article by Duffie\cite{Duffie2001}.



I also tried \nocite to find the whole list but to no avail. All I got was just an empty reference list.

I read some of the older posts here with similar problem and I used a minimal-application to test out my bib, foo.tex to try to work with it. And I encountered similar problem.

I have also read that for everytime the .bib is read into the TexMaker, an aux file will be introduced with the citation appended to it. And indeed there is such file, but I still can't generate .bbl file. Please help.

Here is the foo.bib file generated by Jabref

% This file was created with JabRef 2.6.
% Encoding: Cp1252

author = {Bjork, Tomas},
title = {{Topics in Interest Rate Theory}},
journal = {Handbooks in OR \& MS},
year = {2008},
volume = {15},
pages = {377-435},
timestamp = {2011.03.09} }

title = {{Dynamic Asset Pricing Theory}},
year = {2001},
author = {Duffie, Darrell},
edition = {3}

title = {{Stochastic Differential Equations - An Introduction with Applications}},
year = {2003},
author = {Oksendal, Bernt},
edition = {6}

here is the .aux file that's generated:


I have attached several files(MWA that was used here before, log file, and the bib file)

Here is the screen-cap of the setting and quick-build screen:


  • Welcome to tex.sx! A tip: If you indent lines by 4 spaces, then they are marked as a code sample. You can also highlight the code and click the "code" button (with "101010" on it).
    – lockstep
    Commented Mar 9, 2011 at 6:50
  • 2
    Did you actually run bibtex?
    – TH.
    Commented Mar 9, 2011 at 7:48
  • 1
    I think TH has probably diagnosed your problem. In your first screenshot, it seems that you have told TeXMaker to run JabRef instead of bibtex at the stage when TeXMaker would ordinarily run bibtex to generate a .bbl file from your .bib file. Replacing "C:/Program Files (x86)/JabRef/JabRef.exe" with bibtex should fix your problem.
    – las3rjock
    Commented Mar 9, 2011 at 7:58
  • Just to share my experience ... it is useful to check the file with extension blg, because it contains the errors of the bibtex compilation ... in my case the \bibliographystyle{plain} was missing and could find this error thanks to this .blg file .... also the following works! latex bibtex latex pdfLatex Pdf Viewer
    – user18841
    Commented Sep 17, 2012 at 20:36

1 Answer 1


Thank you everyone!

I have experimented a bit further, and some nice folk at LaTex community helped me figure out what's wrong.
In my 'Configure Texmaker', i actually had the wrong setting (as you can see form the screen cap)
I changed it back to "bibtex %.aux" and now it works!

And I also set the quickBuild to

Pdf Viewer

now it builds the bll and view the pdf automatically. Thank you so much everyone!

P.S. Thank you lockstep, from now on I will use the code button.
P.P.S.And TH, yea, that was the problem, I set the JabRef in the bibTex (I naively thought JabRef will help me compile the bib file).

  • Yes. las3rjock. That was exactly the problem, thank you for taking your time to look through my screen-caps. Thank you so much. Commented Mar 9, 2011 at 8:01
  • 1
    I'm glad you found and fixed your problem. JabRef is a great program that can do many things, but generating .bbl files from .bib files is not one of them. :-)
    – las3rjock
    Commented Mar 9, 2011 at 8:04
  • please mark your answer as correct
    – rafee
    Commented Jun 15, 2014 at 19:24
  • 1
    @CorneliusJack I am facing a similar problem. Could u help me out? Commented Aug 18, 2015 at 15:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .