LuaLaTeX does not use the correct font shape.

The following minimal example



\setmainfont{DejaVu Serif}
\setsansfont{DejaVu Sans}
\setmonofont{DejaVu Sans Mono}


    This is a Test.

    \textbf{This is a Test.}

    \textsf{This is a Test.}

    \textsf{\textbf{This is a Test.}}

    \texttt{This is a Test.}

compiled with TexLive 2013 results in the following document:

Result of Compilation

Instead of using normal DejaVuSans, ExtraLight shape is embedded into the document. But the correct bold font is used.

Compiling this document with TexLive 2012, the correct fonts are used.

 minimal.cls    2001/05/25 Standard LaTeX minimal class
fontspec.sty    2013/05/20 v2.3c Font selection for XeLaTeX and LuaLaTeX
   expl3.sty    2013/07/28 v4582 L3 Experimental code bundle wrapper
 l3names.sty    2012/12/07 v4346 L3 Namespace for primitives
l3bootstrap.sty    2013/07/28 v4581 L3 Experimental bootstrap code
  luatex.sty    2010/03/09 v0.4 LuaTeX basic definition package (HO)
infwarerr.sty    2010/04/08 v1.3 Providing info/warning/error messages (HO)
ifluatex.sty    2010/03/01 v1.3 Provides the ifluatex switch (HO)
    etex.sty    1998/03/26 v2.0 eTeX basic definition package (PEB)
luatex-loader.sty    2010/03/09 v0.4 Lua module loader (HO)
pdftexcmds.sty    2011/11/29 v0.20 Utility functions of pdfTeX for LuaTeX (HO)
 ltxcmds.sty    2011/11/09 v1.22 LaTeX kernel commands for general use (HO)
   ifpdf.sty    2011/01/30 v2.3 Provides the ifpdf switch (HO)
l3basics.sty    2013/07/28 v4581 L3 Basic definitions
 l3expan.sty    2013/07/24 v4565 L3 Argument expansion
    l3tl.sty    2013/07/28 v4581 L3 Token lists
   l3seq.sty    2013/07/28 v4581 L3 Sequences and stacks
   l3int.sty    2013/07/28 v4581 L3 Integers
 l3quark.sty    2013/07/21 v4564 L3 Quarks
   l3prg.sty    2013/07/28 v4581 L3 Control structures
 l3clist.sty    2013/07/28 v4581 L3 Comma separated lists
 l3token.sty    2013/07/28 v4581 L3 Experimental token manipulation
  l3prop.sty    2013/07/28 v4581 L3 Property lists
   l3msg.sty    2013/07/28 v4581 L3 Messages
  l3file.sty    2013/07/28 v4581 L3 File and I/O operations
  l3skip.sty    2013/07/28 v4581 L3 Dimensions and skips
  l3keys.sty    2013/07/28 v4581 L3 Experimental key-value interfaces
    l3fp.sty    2013/07/09 v4521 L3 Floating points
   l3box.sty    2013/07/28 v4581 L3 Experimental boxes
l3coffins.sty    2012/09/09 v4212 L3 Coffin code layer
 l3color.sty    2012/08/29 v4156 L3 Experimental color support
l3luatex.sty    2013/07/28 v4581 L3 Experimental LuaTeX-specific functions
l3candidates.sty    2013/07/24 v4576 L3 Experimental additions to l3kernel
  xparse.sty    2013/07/28 v4582 L3 Experimental document command parser
luaotfload.sty    2013/07/23 v2.3b OpenType layout system
luatexbase.sty    2013/05/11 v0.6 Resource management for the LuaTeX macro programmer
luatexbase-compat.sty    2011/05/24 v0.4 Compatibility tools for LuaTeX
luatexbase-modutils.sty    2013/05/11 v0.6 Module utilities for LuaTeX
luatexbase-loader.sty    2013/05/11 v0.6 Lua module loader for LuaTeX
luatexbase-regs.sty    2011/05/24 v0.4 Registers allocation for LuaTeX
luatexbase-attr.sty    2013/05/11 v0.6 Attributes allocation for LuaTeX
luatexbase-cctb.sty    2013/05/11 v0.6 Catcodetable allocation for LuaTeX
luatexbase-mcb.sty    2013/05/11 v0.6 Callback management for LuaTeX
fontspec-patches.sty    2013/05/20 v2.3c Font selection for XeLaTeX and LuaLaTeX


After a reinstallation of TexLive 2013 from a DVD everything worked as expected.

Then I updated the luaotfload-package (30701 -> 31286) and the error was there again.

While running LuaLaTeX I got the following message:

luaotfload | db : Version mismatch; expected 2.207, got 2.204
luaotfload | db : Force rebuild
luaotfload | db : Version mismatch; expected 2.207, got 2.204
luaotfload | db : Force rebuild(load luc: /usr/local/texlive/2013/texmf-var/luatex-cache/generic/fonts/otf/dejavuserif.luc)

This was repeated multiple times (for every dejavu-font on my system, as it seems) and happend every time I run LuaLaTeX.

With luaotfload-tool --force --update -v I rebuilt the fonts database and the next run of lualatex was without those forced rebuilds. But sadly, the output is still the same.

  • I get correct output both with TeX Live 2012 and 2013
    – egreg
    Aug 26, 2013 at 8:48
  • 2
    The dev version of luaotfload has some tweaks to the font matching. On my machine it picks the correct fonts: i.imgur.com/5t61jDR.png Aug 26, 2013 at 8:49
  • 2
    Works fine for me too (miktex + TL13 on windows 7) Aug 26, 2013 at 9:37
  • I even deleted luaotfload-names.lua so that luaotfload had to rebuild the font names database, but the result was the same.
    – leviathan
    Aug 26, 2013 at 9:54
  • 1
    I reinstalled TexLive 2013 from a DVD and the problem was gone. Sadly after I updated my TexLive installation, I face the same problem again.
    – leviathan
    Aug 27, 2013 at 7:52

1 Answer 1


Okay, the problem was not with TexLive at all.

I reinstalled ttf-dejavu (I'm working on an Ubuntu-machine) and now everything works like a charm.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .