5

Page break, New page, Clear page, Clear double page functions does not work for me in LyX. I tried to enter them via Insert ->.... and via LaTeX code \pagebreak etc.

But I desperately need to brake a page between two figures, because second picture occur inside the next subsection on the next page and that new subsection starts (in compiled PDF) right after the first figure. These two figures are too big to be placed at one page.

EDIT: MWE can be downloaded here

EDIT 2: Here is the screenshot for MWE: enter image description here

LyX version 2.0.6, OS openSUSE 12.3.

  • This sounds more like a figure placement than a page break issue. Could you add a MWE that demonstrates the problem? – vaettchen Aug 26 '13 at 16:46
  • @vaettchen, what is MWE? May be you are right, but if I could break page there then there would be no problem placing figure right before next subsection. – SS_Rebelious Aug 26 '13 at 17:17
  • 1
    Please, take a look at minimal working example (MWE) – user13907 Aug 26 '13 at 17:31
  • and a LyX minimal example: wiki.lyx.org/FAQ/MinimalExample – scottkosty Aug 26 '13 at 20:08
  • 1
    Yes, the first figure ends up on page 1 (same as chapter heading), second figure on page 2, followed by section 1.2. However, I think that may be because I had A4 paper size, if I switch to US Letter I get the same output that you get. Edit: Concerning my last comment, I had misunderstood the issue a little, your screenshot cleared that up. You could set the first figure to be on a Page of floats. – Torbjørn T. Aug 27 '13 at 16:45
1

This is a problem of float placement, more than page breaking. One way around this specific issue seems to make the first figure be placed on a float page, i.e. a page containing only floats. To do that, go into the settings for the float by right clicking on the inset "title" (circled in below screenshot), and choosing Settings. Here, uncheck Use default placement and check Page of floats:

Again, for this specific case, it seems the first figure will fit on the first page if the paper size is set to A4, rather than US Letter. If A4 is what you really want to use, go to Document --> Settings --> Document Class, and add a4paper to the custom class options.

enter image description here

3

You can add without any writing, just go to menu bar. As simple as that:

enter image description here

  • 4
    The OP mentioned they tried this and it didn't work for them... – Werner Apr 29 '15 at 15:17
1

I suspect that the code you're inserting to force the pagebreak is getting lost w/ the figure calculations.

Instead, what you should do is erect a \FloatBarrier using the placeins package, I believe there's an option to prevent floats from appearing in a following section. There's some discussion of this in the TeX FAQ: http://www.tex.ac.uk/cgi-bin/texfaq2html?label=floats

  • Thank you, it works. Unfortunately this methods brakes page right after the second figure, and I don't need this because it leaves a relatively small figure to occupy the whole page. BTW, I added MWE to the question. – SS_Rebelious Aug 27 '13 at 15:30
0

Combining the following three worked for me: 1) Insert -> Formatting -> New Page 2) Insert -> Formatting -> Ligature Break 3) Insert -> Formatting -> New Page

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.