9

The default letter spacing for small capitals seem optimised for use in headlines and such but a bit too cramped for use in abbreviations. How should I do to get the letter spacing more suitably bigger for abbreviations?

Also, I am using the memoir class and \usepackage[osf]{mathpazo}.

3 Answers 3

7

Use the microtype package and its tracking option. Use the letterspace option for finetuning.

\documentclass{article}

\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}

\usepackage[osf]{mathpazo}

\usepackage[%
%  tracking=smallcaps,
%  letterspace=50,% default: 100
]{microtype}

\newcommand*{\abbrev}[1]{\textls[50]{\textsc{#1}}}

\begin{document}

\Huge

Some text \textsc{in small caps}.

Some text \abbrev{in small caps}.

\end{document}

EDIT: While some of microtype's features (notably automatic font expansion) don't work with bitmap fonts, tracking/letterspacing may work. I haven't tested this thoroughly, though.

EDIT 2: Example modified in order to letterspace only within specific macro.

3
  • Hm, this is going to change all small caps, right? It's actually only in abbreviations the spacing needs to be changed. For headings and such it's fine as it is.
    – jonalv
    Commented Mar 9, 2011 at 12:37
  • Hm actually it seems not: ! pdfTeX error (font expansion): auto expansion is only possible with scalable fonts.
    – jonalv
    Commented Mar 9, 2011 at 13:33
  • @jonalv: I updated my example. (It also works with mathpazo.)
    – lockstep
    Commented Mar 9, 2011 at 14:40
4

I would rather use the soul package. You can define a macro to make it easier to typeset the abbreviations as follows:

\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[osf]{mathpazo}
\usepackage{soul}

%\usepackage[%
%  tracking=smallcaps,
%  letterspace=50,% default: 100
%]{microtype}

\def\abbreviation#1{\textsc{\so{#1}}
}

\begin{document}
\textsc{nato}

\abbreviation{nato}
\end{document}

Uncomment the microtype package code above to see the differences.

2
  • Hm we posted almost simultaneosly. Your example does however not fine tune the spacing and the default from your example is giganormous! :)
    – jonalv
    Commented Mar 9, 2011 at 14:26
  • @jonalv ... it happens, but I am glad you found the solution to your problem. Did not post any settings being confident that you would be interested in reading the manual. Some good settings can be found in the tufte-book class. Search for the definition of newthought.
    – yannisl
    Commented Mar 9, 2011 at 15:01
0

I ended up going with the soul package because it seemed microtype did not work with the font I was using:

(Edit: apparantly it was possible to get it to work though)

\documentclass[10pt]{memoir}
\usepackage[T1]{fontenc}
\usepackage[osf]{mathpazo}
\usepackage{soul}

\newcommand{\abbrev}[1]{\null\so{\textsc{#1}}\null}

\begin{document}
\sodef\so{}{0.1em }{0em}{0em}

So now I can write \abbrev{usa} instead of \textsc{usa}.

\end{document}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .