2

I'm using classicthesis 4.1 in LyX to write my thesis and I need help with natbib's citation style.

I can't seem to change the natbib numerical citation style to (Author et al., XXXX; Author2 et al., YYYY).

I have this current line, however, I cant find the right place to put it to make it work:

\usepackage[authoryear,round,colon]{natbib}

Present situation:

present

Desired result:

goal

PS. I am aware that the classicthesis manual states:

Citation format is governed by the natbib numerical style invoked in the document settings of the main thesis file (beware, options chosen in classicthesis-config.tex will have no effect).

1

This seems to do what you want:

\begin{filecontents*}{abcdefg.bib}
@ARTICLE{sievers07,
   author = {{Sievers}, J.~L. and {Achermann}, C. and {Bond}, J.~R. and {Bronfman}, L. and
    {Bustos}, R. and {Contaldi}, C.~R. and {Dickinson}, C. and {Ferreira}, P.~G. and
    {Jones}, M.~E. and {Lewis}, A.~M. and {Mason}, B.~S. and {May}, J. and
    {Myers}, S.~T. and {Oyarce}, N. and {Padin}, S. and {Pearson}, T.~J. and
    {Pospieszalski}, M. and {Readhead}, A.~C.~S. and {Reeves}, R. and
    {Taylor}, A.~C. and {Torres}, S.},
    title = "{Implications of the Cosmic Background Imager Polarization Data}",
     journal   = "Astrophys. J.",
     year = "2007",
    pages = {976-987},
}

@book{goossens93,
    author = "Michel Goossens",
    title = "The {LaTeX} Companion",
    year = "1993",
    publisher = "Addison-Wesley",
    address = "Reading, Massachusetts"
}
\end{filecontents*}
\documentclass{scrbook}
\usepackage[T1]{fontenc}
\usepackage{classicthesis}

\usepackage[authoryear,round,colon]{natbib}
\hypersetup{colorlinks=true,citecolor=cyan}% just for the example

\begin{document}

\citep{sievers07,goossens93}
\bibliographystyle{plainnat}
\bibliography{abcdefg}

\end{document}

enter image description here

  • Again, thank you for your answer. I still can't make it work. Where should I put your solution, and which part of it? What I already have in classicthesis-config.tex: \PassOptionsToPackage{square,numbers}{natbib} \usepackage{natbib} – SplitteMineBramsejl Aug 30 '13 at 18:59
  • @user212704 You're welcome. Try removing those lines from classicthesis-config.tex and use \usepackage[authoryear,round,colon]{natbib} in the preamble of your actual document. The filecontents* environment in my example code is not essential (you don't need it in your document); it was just to make my example self-contained. – Gonzalo Medina Aug 30 '13 at 20:14
  • After doing that, it seems that my natbib update clashes with a style already loaded. The returning error message: "LaTeX Error: Option clash for package natbib. The package natbib has already been loaded with options: [numbers] There has now been an attempt to load it with options [authoryear,round,colon] Adding the global options: numbers,authoryear,round,colon to your \documentclass declaration may fix this." However, I can't find where the natbib is loaded. – SplitteMineBramsejl Aug 30 '13 at 20:27
  • @user212704 Then remove that line from your document and load the class with the global options: \documentclass[authoryear,round,colon]{scrbook}. – Gonzalo Medina Aug 30 '13 at 20:29
  • @user212704 in the default classicthesis-config.tex natbib is loaded in line 83: \PassOptionsToPackage{square,numbers}{natbib} \usepackage{natbib}. If you have the default file, you could also do the change there. – Gonzalo Medina Aug 30 '13 at 20:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.