I'm running into a bizarre issue with the Babel package that I haven't seen before and would love some help figuring out a solution.

First, I'll give an example of something that does compile correctly (using pdftex) on my computer:

\usepackage[hebrew, english]{babel}
Document Text.

However, when I remove the word hebrew, it no longer compiles and gives me the following error (taken from the log file):

! Undefined control sequence.
\bbl@set@language ...ge {\languagename }}\bbl@for 
                                                  \bbl@tempa \BabelContentsF...
l.6 \begin{document}

! Emergency stop.
\bbl@set@language ...ge {\languagename }}\bbl@for 
                                                  \bbl@tempa \BabelContentsF...
l.6 \begin{document}

End of file on the terminal!

I have noticed that the same error occurs when using Arabic and English.

I just recently updated to TeX Live 2013; I also just updated all my packages. After running into this issue, I reinstalled all babel packages with the TeX Live Utility and tried to compile the document again with no luck.

I also just recently installed GNU Aspell with a bunch of dictionaries, including Arabic, Hebrew, and English. I can't imagine that would cause this issue, but I thought I'd mention it. Also, I am on a Mac.

Here is output from \listfiles for the english document:

! Undefined control sequence.
\bbl@set@language ...ge {\languagename }}\bbl@for 
                                                  \bbl@tempa \BabelContentsF...
l.6 \begin{document}

? r
OK, entering \nonstopmode...


 *File List*
 article.cls    2007/10/19 v1.4h Standard LaTeX document class
  size10.clo    2007/10/19 v1.4h Standard LaTeX file (size option)
inputenc.sty    2008/03/30 v1.1d Input encoding file
    utf8.def    2008/04/05 v1.1m UTF-8 support for inputenc
   t1enc.dfu    2008/04/05 v1.1m UTF-8 support for inputenc
  ot1enc.dfu    2008/04/05 v1.1m UTF-8 support for inputenc
  omsenc.dfu    2008/04/05 v1.1m UTF-8 support for inputenc
   babel.sty    2005/11/23 v3.8h The Babel package
 english.ldf    2005/03/30 v3.3o English support from the babel system
   t1enc.def    2005/09/27 v1.99g Standard LaTeX file

  • 1
    Have you tried deleting the .aux file? Changing babel languages generally requires it. – Lev Bishop Sep 1 '13 at 2:47
  • Yes I have - I still get the same error message. – lish Sep 1 '13 at 3:42
  • Sounds like a job for \listfiles. Could you add that to the input and edit in the *File list* you get from the log? I guess you might need to do two runs, one with just english and one with just hebrew as the babel options. – Joseph Wright Sep 1 '13 at 7:11
  • Try to press r when the terminal pauses and hit enter and do this twice. – Sigur Sep 1 '13 at 10:27
  • 2
    You have a very outdated Babel subsystem somewhere; with TeX Live 2013 it should be babel.sty 2013/05/16 v3.9f. Look for babel.sty in the log file and report the path where the file is loaded from. – egreg Sep 1 '13 at 21:40

It turns out that I had an outdated version of babel in my Library folder (/Users/username/Library/texmf/tex/latex/babel/). After deleting this outdated version, LaTeX used the correct, updated version found in the 2013 distribution (/usr/local/texlive/2013/texmf-dist/tex/latex/generic/babel/). Documents now compile correctly!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.