8

I am not all that experienced in using the achemso style package. I am trying to prepare an article for Environmental science & research. They want the references as super-scripted numbers in the end of the sentences after the punctuation.

To my understanding this should be the default when using:

\documentclass[journal=esthag,manuscript=article]{achemso}

using in the text \cite{nameofarticle_xxxx} and implementing the bibliography file as: \bibliography{nameofbibfile}.

However my references show up as numbers in normal text and before the punctuation mark. How do I get them super scripted and behind the punctuation mark? Is there a setting I am missing?

The following MWE shows the issue:

\documentclass[journal=esthag,manuscript=article]{achemso}
\setkeys{acs}{super=true}
\begin{filecontents}{acsdemo.bib}
@ARTICLE{Abernethy2003,
  author = {Colin D. Abernethy and Gareth M. Codd and Mark D. Spicer
    and Michelle K. Taylor},
  title = {{A} highly stable {N}-heterocyclic carbene complex of
    trichloro-oxo-vanadium(\textsc{v}) displaying novel
    {C}l---{C}(carbene) bonding interactions},
  journal = {{J}. {A}m. {C}hem. {S}oc.},
  year = {2003},
  volume = {125},
  pages = {1128--1129},
  number = {5},
  doi = {10.1021/ja0276321},
}
\end{filecontents}
\title{Demo title}
\begin{document}
This is a citation\cite{Abernethy2003}.
\bibliography{acsdemo}
\end{document}

enter image description here

Any help is most appreciated

  • Look at the package documentation: sse the super package option. Placing the super-scripted number before the punctuation should be the default, see Sec. 7 'The natmove package' in the docs. – Christoph Sep 4 '13 at 9:19
  • I have tried adding the following line, but it does not seem to make any difference: \setkeys{acs}{super=true}. And I have read the info on the natmove package and agree it should be the default, however my output does not show up the intended way. Also I use miktex in combination with texmaker, could this cause it not to behave? – Helle Sep 4 '13 at 9:21
  • You are right, setting the super option seems not to work. With journal=esthag I could not switch on the superscripts, and with journal=jacsat, which is what achemso-demo.tex uses, I couldn't switch it off. I'll post an answer as addition to your question. – Christoph Sep 4 '13 at 9:44
8

This is an error in achemso which will be fixed in the next release. For the moment, doing

\documentclass[journal=esthag,manuscript=article]{achemso}
\setkeys{acs}{super = true}
\setcitestyle{super,open={},close={}}
\def\citenumfont{}

should correct the issues: this resets the flag for achemso and alters the appropriate natbib settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.