5

I have used a tex template for my CV for years. But I recently migrated everything to a new Mac running OS 10.8.4 and the document will no longer compile. I have confirmed that the file compiles fine on OS 10.7.5. I'm working with the latest MacTex distribution on both computers.

The error generated is:

! Incomplete \iffalse; all text was ignored after line 113.

Line 113 is the first usage:

/ressubheading

in this block:

\documentclass[letterpaper,10pt]{article}
\newlength{\outerbordwidth}
\pagestyle{empty}
\raggedbottom
\raggedright
\usepackage[svgnames]{xcolor}
\usepackage{hyperref}
\usepackage{framed}
\usepackage{tocloft}
\usepackage{textcomp}
\usepackage{hanging}
\usepackage{geometry}
\usepackage{url}
\usepackage{hyperref}
\usepackage{lastpage}
\usepackage{fancyhdr}
\usepackage{color,soul}
\usepackage{framed}


% settings for hyperlinks
\hypersetup{
    bookmarks=true,         % show bookmarks bar?
    unicode=false,          % non-Latin characters in AcrobatÕs bookmarks
    pdftoolbar=true,        % show AcrobatÕs toolbar?
    pdfmenubar=true,        % show AcrobatÕs menu?
    pdffitwindow=false,     % window fit to page when opened
    pdfstartview={FitH},    % fits the width of the page to the window
    pdftitle={My Title},    % title
    pdfauthor={Me},     % author
    pdfsubject={Subject},   % subject of the document
    pdfcreator={Creator},   % creator of the document
    pdfproducer={Producer}, % producer of the document
    pdfkeywords={keywords}, % list of keywords
    pdfnewwindow=true,      % links in new window
    colorlinks=true,       % false: boxed links; true: colored links
    linkcolor=red,          % color of internal links
    citecolor=green,        % color of links to bibliography
    filecolor=magenta,      % color of file links
    urlcolor=blue           % color of external links
}


%-----------------------------------------------------------
%Edit these values as you see fit

\setlength{\outerbordwidth}{2.5pt}  % Width of border outside of title bars
\definecolor{shadecolor}{gray}{0.75}  % Outer background color of title bars (0 = black, 1 = white)
\definecolor{shadecolorB}{gray}{0.9}  % Inner background color of title bars


%-----------------------------------------------------------
%Margin setup

\setlength{\evensidemargin}{-0.25in}
\setlength{\headheight}{0in}
\setlength{\headsep}{0in}
\setlength{\oddsidemargin}{-0.25in}
\setlength{\paperheight}{11in}
\setlength{\paperwidth}{8.5in}
\setlength{\tabcolsep}{0in}
\setlength{\textheight}{9.0in}
\setlength{\textwidth}{7in}
\setlength{\topmargin}{-0.3in}
\setlength{\topskip}{0in}
\setlength{\voffset}{0.1in}


%-----------------------------------------------------------
%Custom commands
\newcommand{\resitem}[1]{\item #1 \vspace{-2pt}}
\newcommand{\resheading}[1]{\vspace{8pt}
  \parbox{\textwidth}{\setlength{\FrameSep}{\outerbordwidth}
    \begin{shaded}
\setlength{\fboxsep}{0pt}\framebox[\textwidth][l]{\setlength{\fboxsep}   {4pt}\fcolorbox{shadecolorB}{shadecolorB}{\textbf{\sffamily{\mbox{~}\makebox[6.762in][l]{\large #1} \vphantom{p\^{E}}}}}}
    \end{shaded}
  }\vspace{-7pt}
}
\newcommand{\ressubheading}[4]{
\begin{tabular*}{6.5in}{l@{\cftdotfill{\cftsecdotsep}\extracolsep{\fill}}r}
    \textbf{#1} & #2 \\
    \textit{#3} & \textit{#4} \\
\end{tabular*}\vspace{-6pt}}

%-----------------------------------------------------------


\begin{document}

%%%%%%%%%%%%%%%%%%footer settings
\pagestyle{fancy}
\fancyhf{} % clear all header and footer fields
\fancyfoot[L]{\footnotesize \hspace{0.5in}J. A. Smith}
\fancyfoot[C]{\footnotesize \textit{Curriculum Vitae}}
\fancyfoot[R]{\footnotesize Page \thepage\ of 1 \hspace{0.5in}}
\renewcommand{\headrulewidth}{0pt}
\renewcommand{\footrulewidth}{0pt}
%%%%%%%%%%%%%%%%%%end footer settings

\begin{tabular*}{7in}{l@{\extracolsep{\fill}}r}
\textbf{\Large Joeseph A. Smith}\\
Assistant Professor -- Department of Biological Sciences\\
Curator of Mammals -- Museum of Natural Science\\
\url{http://www.foo.edu/Smith} & \href{mailto:Smith@xxx.edu}{\nolinkurl{Smith@xxx.edu}}
\end{tabular*}
    %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
\resheading{Education}
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
\begin{itemize}
    \item
        \ressubheading{University of Foo}{Foo}{Ph.D. Ecology \& Evolutionary Biology}{2010}
        \begin{itemize}
            \resitem{Dissertation Title: blah blah}
    \end{itemize}

    \item
    \ressubheading{Boo State University}{Boo}{B.S. Biology}{2000}
\end{itemize}


\end{document}    

It's hard to believe this a problem with the code (even though that's what the error suggests), given that it compiles fine on the earlier OS, but I am not very experienced at customizing tex docs. Thanks in advance for any help!

  • 2
    Show a complete example. – Ulrike Fischer Sep 4 '13 at 14:22
  • Are you loading babel? – egreg Sep 4 '13 at 14:34
  • 1
    The most important method for debugging is creating a minimal example (or here): just by constructing it, you (yourself) are likely to figure out what is going wrong. ... And if not, someone here is likely to be able to figure it out on the basis of the MWE. – jon Sep 4 '13 at 14:53
  • @egreg No, not using babel. – Jake Sep 4 '13 at 14:54
  • @jon I edited the question to contain a complete, but minimal code block that generates the errors on OS10.8 but not 10.7. – Jake Sep 4 '13 at 15:05
6

The most recent version of tocloft has redefined \cdotfill in a way that seems not to agree with your usage of it in \ressubheading.

I don't really know what you're using it for, but anyway here are two fixes:

  1. \usepackage{array} in the preamble (which works because the table preamble is not subject to expansion any more)

  2. \protect\cftdotfill in the definition of \ressubheading (which achieves the same result)

However, if I use

\begin{tabular*}{6.5in}{l@{\extracolsep{\fill}}r}

I get the same result.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.