4

I found many solutions to similar problems here, but I still cannot solve this one: I'm using Springer's template like this:

 \documentclass[twocolumn, natbib]{svjour3}     
 \usepackage{graphicx}
 \usepackage{natbib}
 ...
 \bibliographystyle{spbasic}      % basic style, author-year citations
 \bibliography{my_bibliography}

and I get an error: Bibliography not compatible with author-year citations.

I really cannot figure out what I'm doing wrong.

  • @Mico you could make that an answer. – Johannes_B Oct 5 '15 at 12:54
2

(This answer is transferred from a comment I left some time ago.)

The bibliography style you've selected, spbasic, appears to be geared towards numeric citation styles. By default, natbib tries to do authoryear-style citations. To force it to generate numeric-style citations, load the natbib package with the option numbers.

If you really do want to do authoryear-style citation call-outs, you'll probably have to select a different bibliography style.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.