8

I just realized that when using ieee style in biblatex, when two articles in my bibliography share the same authors, the second article the authors disappear and a line is used instead. Is there any easy way to change this behavior without changing the style?

8

In version v1.2 (2016/12/30) of biblatex-ieee, Joseph Wright added full support for the dashed option (https://github.com/josephwright/biblatex-ieee/issues/30). It is now enough to say

dashed=false

The old version of this answer is retained for historic interest and for those who don't have access to a newer version of biblatex-ieee or users of a similar style that does not have an option to turn off the dashed behaviour.

Normally – that is in the standard styles, this is as easy as adding dashed=false to the load options of biblatex. The biblatex styles ieee and ieee-alphabetic, however, do not recognize this option, since – as @Joseph Wright pointed out – it is IEEE style to use the dash.

So you can either manually alter the author macro or disable an internal test needed for the dashed function.

To change the author macro to avoid dashes, just add the following code snippet to your preamble.

\renewbibmacro*{author}{%
  \ifboolexpr{
    test \ifuseauthor
    and
    not test {\ifnameundef{author}}
  }
    {%
      \printnames{author}%
      \iffieldundef{authortype}
        {}
        {%
          \setunit{\addcomma\space}%
          \usebibmacro{authorstrg}%
        }%
    }
    {\global\undef\bbx@lasthash}%
}

Alternatively, you can modify the macro that saves the hash needed for author comparison to do nothing.

\renewbibmacro*{bbx:savehash}{}

MWE

\documentclass[ngerman, a4paper]{article}
\usepackage[latin1]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{babel}
\usepackage{csquotes}
\usepackage[style=ieee-alphabetic, backend=bibtex]{biblatex}
\addbibresource{\jobname.bib}

\renewbibmacro*{bbx:savehash}{}

\begin{filecontents}{\jobname.bib}
@book{UthorA,
  author  = {Arnold Uthor},
  title   = {The Twice Intensely Tiring Lines of Erudition},
  year    = {1983},
}
@article{UthorB,
  author        = {Arnold Uthor},
  title         = {A Very Interesting Article},
  journaltitle  = {Journal of Articles},
  year          = {2000},
}
\end{filecontents}

\begin{document}
  \nocite{*}
  \printbibliography
\end{document}

enter image description here

  • 2
    Note that the reason the styles don't currently recognise this option is that the IEEE style is to use dashes. – Joseph Wright Sep 5 '13 at 6:56
  • 1
    I've recently updated the style to add dashed as an option, to allow people to run it off if they need to – Joseph Wright Jan 4 '17 at 15:59
0

This is answered here: Is it normal for BibTeX to replace similar author names with "------"?

If you are writing a paper which asks for IEEEtrans (especially if this is to be published with IEEE), I would seriously consider simply using the default behavior as the result for your paper. This is not a "fluke" that needs to be programed around, this is exactly how the style is programed and designed to perform.

You should always write your paper and choose your citation style based upon the style guide which has authority over your writing (teacher's choice, university style guide, corporate style guide, Chicago, APA, MLA, AP, &c.) and not your personal preferences.

0

Try to add the following lines to your Bibtex file:

@IEEEtranBSTCTL{IEEEexample:BSTcontrol,
  CTLdash_repeated_names = "no"
}

And the following line to your Tex file, just after \begin{document}:

\begin{document}
\bstctlcite{IEEEexample:BSTcontrol}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.