5

Maybe, I am doing something wrong, but please have a look on the alignment in this formula:

% arara: lualatex

\documentclass{article}
\usepackage{mathtools}
\usepackage[%
    ,math-style=ISO
    ]{unicode-math}

\begin{document}
$f(T)= T\cdot \dots$
\end{document}

enter image description here

That's not very beautiful. The "T" headnuts the right bracket and there is a lot of free space below the T (the brackets are too low). I could add some \, or similar, but I guess, I just don't know how to set a function.


Edit: The compilation with XeLaTeX works fine. But I need it with LuaLaTeX. The Lua-version is: "LuaTeX, Version beta-0.76.0-2013062820 (rev 4627)" I am getting a lot of

luaotfload | load : auto-selecting default features for script: dflt
luaotfload | load : path lookup of "latinmodern-math.otf" unsuccessful, falling 
back to file:

in my main.log

  • 2
    At least on my system (TL2013, fairly recently updated) the output of your example has correct spacing (both with Lua- and XeTeX). – Caramdir Sep 5 '13 at 14:20
  • I've added my filelist. Maybe you could have a look if you can see the old package. My MiKTeX 2.9 is fresh installed and up to date. There is no good practise for setting functions like f(x), isn't there? – LaRiFaRi Sep 5 '13 at 14:28
  • 2
    regarding the "space below" within the parentheses, the height and depth of the parentheses are designed to accommodate letters like the "f", where you can see that the space above and below is symmetrical. in math (for which these fonts were designed), you don't want different sized parentheses for simple expressions that are baseline-aligned; it simply looks ugly. – barbara beeton Sep 5 '13 at 14:45
  • @barbarabeeton Thank you, I just noticed that symmetry to the "f" when I uploaded my picture. Well then I think I just have some horizontal problems here. – LaRiFaRi Sep 5 '13 at 14:49
  • More important than the file list you posted are probably the versions of LuaTeX (beta-0.76.0-2013061708 (TeX Live 2013) (rev 4627) on my system) and latinmodern-math.otf (1.958). Also, try compiling with xelatex and see if the output is better. – Caramdir Sep 5 '13 at 14:52
10

The file luatex-unicode-letters.tex differs between TL2013 and MiKTeX. The TL version deactivates (comments) all entries from \l 1D400 to \l 1D7CB and contains the comment:

 % XXX: luatex math italic correction bug
 % http://www.tug.org/pipermail/tex-live/2011-October/030295.html

This sound as if there is a bug in LuaTeX and Tex Live has implemented a workaround by not setting some catcodes. If I copy the luatex-unicode-letters.tex to MiKTeX, update the FNDB and recreate the LuaLaTeX format the spacing is correct in MiKTeX too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.