I thought I'd change the font to something none standard from the list of font available on my computer. When I tried to compile the following document, the text that should appear along the spokes was scattered all about the page.



        minimum size=1em,
        inner sep=0pt] (C) at (-1,0) {};
  \foreach \x in {1,2,...,12}
      \node[anchor=180+\myRotAngle] at (C) {\rotatebox{\myRotAngle}{\hspace*{1.5em}(\x)text along spokes}};
      \node[circle,draw,red,minimum size=4pt,anchor=180+\myRotAngle] (C label \x) at ([shift={(\myRotAngle:4)}]C) {\textcolor{black}{\aemonth}};
      \draw (C) -- (C label \x);
      \draw (C label \x) -- (C label \prevx);
        \draw (C label 1) -- (C label \prevx);

Resulting in:

enter image description here

Everything works fine if I eliminate the font declaration and compile with pdflatex.

enter image description here

I don't do much, if anything at all, with xelatex. What do I need to do to get xelatex to play nicely with tikz?

The font can be found in Using a handwriting font from myscriptfont.com


I get the same problem if I just use xelatex without worrying about the setting the font with \setmainfont or whether or not I load \usepackage{fontspec}. Per the comments, here's the relevant section of my log file after using \listfiles:

 *File List*
 article.cls    2007/10/19 v1.4h Standard LaTeX document class
  size10.clo    2007/10/19 v1.4h Standard LaTeX file (size option)
fontspec.sty    2013/05/20 v2.3c Font selection for XeLaTeX and LuaLaTeX
   expl3.sty    2013/07/12 v4544 L3 Experimental code bundle wrapper
 l3names.sty    2012/12/07 v4346 L3 Namespace for primitives
l3bootstrap.sty    2013/01/08 v4420 L3 Experimental bootstrap code
    etex.sty    1998/03/26 v2.0 eTeX basic definition package (PEB)
l3basics.sty    2013/07/09 v4521 L3 Basic definitions
 l3expan.sty    2013/07/09 v4521 L3 Argument expansion
    l3tl.sty    2013/04/24 v4482 L3 Token lists
   l3seq.sty    2013/05/26 v4500 L3 Sequences and stacks
   l3int.sty    2013/04/24 v4482 L3 Integers
 l3quark.sty    2013/07/09 v4521 L3 Quarks
   l3prg.sty    2013/04/24 v4482 L3 Control structures
 l3clist.sty    2013/05/26 v4500 L3 Comma separated lists
 l3token.sty    2013/04/24 v4482 L3 Experimental token manipulation
  l3prop.sty    2013/01/09 v4423 L3 Property lists
   l3msg.sty    2013/01/08 v4412 L3 Messages
  l3file.sty    2013/05/01 v4483 L3 File and I/O operations
  l3skip.sty    2013/01/13 v4444 L3 Dimensions and skips
  l3keys.sty    2013/07/12 v4544 L3 Experimental key-value interfaces
    l3fp.sty    2013/07/09 v4521 L3 Floating points
   l3box.sty    2013/04/24 v4482 L3 Experimental boxes
l3coffins.sty    2012/09/09 v4212 L3 Coffin code layer
 l3color.sty    2012/08/29 v4156 L3 Experimental color support
l3luatex.sty    2012/08/03 v4049 L3 Experimental LuaTeX-specific functions
l3candidates.sty    2013/07/09 v4521 L3 Experimental additions to l3kernel
   ifpdf.sty    2011/01/30 v2.3 Provides the ifpdf switch (HO)
  xparse.sty    2013/07/12 v4544 L3 Experimental document command parser
fontspec-patches.sty    2013/05/20 v2.3c Font selection for XeLaTeX and LuaLaTe
fixltx2e.sty    2006/09/13 v1.1m fixes to LaTeX
fontspec-xetex.sty    2013/05/20 v2.3c Font selection for XeLaTeX and LuaLaTeX
  eu1enc.def    2010/05/27 v0.1h Experimental Unicode font encodings
  eu1lmr.fd    2009/10/30 v1.6 Font defs for Latin Modern
xunicode.sty    2011/09/09 v0.981 provides access to latin accents and many oth
er characters in Unicode lower plane
 eu1lmss.fd    2009/10/30 v1.6 Font defs for Latin Modern
graphicx.sty    1999/02/16 v1.0f Enhanced LaTeX Graphics (DPC,SPQR)
  keyval.sty    1999/03/16 v1.13 key=value parser (DPC)
graphics.sty    2009/02/05 v1.0o Standard LaTeX Graphics (DPC,SPQR)
    trig.sty    1999/03/16 v1.09 sin cos tan (DPC)
graphics.cfg    2010/04/23 v1.9 graphics configuration of TeX Live
   xetex.def    2013/04/29 v0.96 LaTeX color/graphics driver for XeTeX (RRM/JK)

  lipsum.sty    2011/04/14 v1.2 150 paragraphs of Lorem Ipsum dummy text
    tikz.sty    2013/08/05 v2.10-cvs (rcs-revision 1.129)
     pgf.sty    2013/08/23 v2.10-cvs (rcs-revision 1.13)
  pgfrcs.sty    2010/11/07 v2.10-cvs (rcs-revision 1.25)
everyshi.sty    2001/05/15 v3.00 EveryShipout Package (MS)
 pgfcore.sty    2010/04/11 v2.10-cvs (rcs-revision 1.7)
  pgfsys.sty    2013/08/23 v2.10-cvs (rcs-revision 1.46)
pgfsyssoftpath.code.tex    2008/07/18  (rcs-revision 1.7)
pgfsysprotocol.code.tex    2006/10/16  (rcs-revision 1.4)
  xcolor.sty    2007/01/21 v2.11 LaTeX color extensions (UK)
   color.cfg    2007/01/18 v1.5 color configuration of teTeX/TeXLive
pgfcomp-version-0-65.sty    2007/07/03 v2.10-cvs (rcs-revision 1.7)
pgfcomp-version-1-18.sty    2007/07/23 v2.10-cvs (rcs-revision 1.1)
  pgffor.sty    2013/07/18 v2.10-cvs (rcs-revision 1.24)
   t3cmr.fd    2001/12/31 TIPA font definitions
  • I've tried some different fonts with XeLaTeX, never getting the wrong output. Of course I don't have the "ScottMorrison" font.
    – egreg
    Sep 7, 2013 at 19:48
  • I can't replicate this.
    – percusse
    Sep 7, 2013 at 19:48
  • Same as @egreg here: all OK if I pick a font I have. Can you add your \listfiles output to the question?
    – Joseph Wright
    Sep 7, 2013 at 19:51
  • I get the same output as A. Ellett once I remove the \setmainfont line. I'm using TL2013 and I tried with both PGF from TL2013 and PGF from CVS. Sep 7, 2013 at 19:54
  • Ah, no. I just updated PGF-CVS to double check and everything went nicely back into place. I recently reported a bug with PGF and XeTeX to do with node placement. It might be that this has been fixed and is now in CVS, and might have been also released to TL2013. So try updating PGF and/or TL and see if it still happens. Sep 7, 2013 at 19:59

1 Answer 1


(Summarising the comments) The problem here is due to a bug in pgfsys-dvipdfmx.def which has been fixed in the latest CVS, so updating PGF is the solution.

The \listfiles command lists the files that register themselves with the LaTeX kernel, but it appears to have missed pgfsys-dvipdfmx.def, so looking through the log is also a good idea. For such files, kpsewhich <filename> shows you where the file is located on your system so that you can work out what version it was.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.