2

When I compile the following code (LaTeX -> pdf) without the option 'subfolder' at the 'gnuplottex'-package, it works fine.

The ps-file 'test-gnuplottex-fig1.ps', automatically created by gnuplottex, is converted to a pdf-file 'test-gnuplottex-fig1-eps-converted-to.pdf' by epstopdf, both files are in the same folder as the main tex-file.

\documentclass{scrartcl}
\usepackage[latin1]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{graphicx}
\usepackage{epstopdf}
\usepackage[miktex,subfolder]{gnuplottex}
\usepackage{latexsym}
\usepackage{keyval}
\usepackage{ifthen}
\usepackage{moreverb}

\begin{document}

\begin{figure}%
\centering
\begin{gnuplot}[terminal=epslatex,terminaloptions=color,scale=1.0]
plot sin(x) notitle
\end{gnuplot}
\caption{}%
\label{}%
\end{figure}

\end{document}

But adding the 'subfolder' option results in the error "Undefined control sequence" at the position in the tex-file where the pdf-file gets included because there's only a ps-file in the subfolder 'gnuplottex', but no pdf-file.

The error remains when I copy the pdf-file 'test-gnuplottex-fig1-eps-converted-to.pdf' to the 'gnuplottex'-subfolder.

How can I get the gnuplottex package to run with the subfolder option?

My system:

  • MikTeX 2.9
  • TeXnicCenter 2.0 Beta 2
  • Windows 7
  • 'gnuplottex'-package version 0.7 (2013/07/23)
2

This is a bug in gnuplottex. I've just uploaded a new version that should fix this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.