3

I have successfully installed the MinionPro font for LaTeX. It works with pdfLaTex. I also changed the number style to lining with:

\usepackage[textlf]{MinionPro}

However if I have a table with numbers, I would like to get numbers in tabular form (monospaced).

I'm looking for an option to write in the preamble that applyies at the entire document and works with pdfLaTeX.

Thank you very much for some hints!

MWE (as requested):

\documentclass[11pt]{scrreprt}
\usepackage[textlf]{MinionPro}
\begin{document}

\figureversion{lf,tab} \begin{table} \begin{tabular}{r|rr}
\bf{-44}    &-2.50  &-1.54  \\ 
\bf{-31}    &-1.14  &-1.17  \\ 
\bf{-22}    &-0.77  &-0.80  \\ 
\bf{-11}    &-0.39  &-0.11  \\ 
\bf{-0} &-0.01  &-0.04  \\
\bf{0}  &0.00   & 0.04  \\ 
\end{tabular} \end{table}

\begin{table} \figureversion{lf,tab} \begin{tabular}{r|rr}
\bf{-44}    &-2.50  &-1.54  \\ 
\bf{-31}    &-1.14  &-1.17  \\ 
\bf{-22}    &-0.77  &-0.80  \\ 
\bf{-11}    &-0.39  &-0.11  \\ 
\bf{-0} &-0.01  &-0.04  \\
\bf{0}  &0.00   & 0.04  \\ 
\end{tabular} \end{table}

\end{document}

In the first example where the figureversion is out of the table it does not have any influence on the table itself.

In the second example, where the figureversion is inside the table it works for the not bold numbers (not for the first column).

enter image description here

  • 1
    Unless you absolutely have to set an option in the preamble you could just write \figureversion{lf,tab} directly after \begin{document}. – DG' Sep 8 '13 at 10:43
  • Thank you for your answer. Your solution is not working within tables. Therefore it is not sufficient for my problem. I would like to avoid to write within every table this option. – Fabio Sep 8 '13 at 15:05
  • @Fabio You could write your own table environment which automatically sets the tabular figures. – sebschub Sep 8 '13 at 16:25
  • @Fabio maybe you could provide a MWE? – DG' Sep 8 '13 at 17:34
  • @DG' I have prepared a MWE. You need to have the MignonPro package installed in MikTeX. – Fabio Sep 8 '13 at 17:58
3

You could add \figureversion to the tabular environment, that way tabular numbers are used for all tables in your document.

\documentclass[11pt]{scrreprt}
\usepackage[textlf]{MinionPro}
\usepackage[toc,eqno,enum,bib,lineno]{tabfigures}

% ------------------------------------
% Add \figureversion{lf,tab} to 
% the tabular-environment

\usepackage{etoolbox}
\AtBeginEnvironment{tabular}{%
    \figureversion{lf,tab} 
}

\begin{document}

\begin{table} 
    \begin{tabular}{r|rr}
        \textbf{-44}    &-2.50  &-1.54  \\ 
        \textbf{-31}    &-1.14  &-1.17  \\ 
        \textbf{-22}    &-0.77  &-0.80  \\ 
        \textbf{-11}    &-0.39  &-0.11  \\ 
        \textbf{ −0}    &-0.01  &-0.04  \\
        \textbf{  0}    & 0.00  & 0.04  \\ 
    \end{tabular}
\end{table}

\end{document}

EDIT: Added \usepackage[toc,eqno,enum,bib,lineno]{tabfigures}

  • This solution is perfect for tables. Thank you! Now, I still have this problem with the table of content: The chapter numbers and the page numbers are shown with proportional numbers and this is not an environment that I can define. 1) Is there a way to correct the numbers of the table of contents (and list of figures/tables)? 2) Is there a way to change the format of the numbers in linear + tabular for the entire document (in every part of the text)? – Fabio Sep 9 '13 at 11:53
  • @Fabio Try the tabfigures package as proposed by Juri. – sebschub Sep 9 '13 at 12:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.