32

I would like to know how to remove the "References" title from command \bibliography{}.

If I write:

... text ... \cite{RefAnd2013} ...
\bibliographystyle{IEEEtran}
\bibliography{AnderBib}
... more text ...
\end{document}

Appears "References" title:

... text [1] ...

References

[1] W. Anderson, Environment Modeling with UML, in ... 2010. [Online]. Available: http://dx.doi.org/xxx

... more text ...

But, I need

... text [1] ...

[1] W. Anderson, Environment Modeling with UML, in ... 2010. [Online]. Available: http://dx.doi.org/xxx

... more text ...

  • 2
    Which document class are you using? – Gonzalo Medina Sep 10 '13 at 18:17
36

Add these lines to the preamble:

\usepackage{etoolbox}
\patchcmd{\thebibliography}{\section*{\refname}}{}{}{}

A complete example:

\begin{filecontents*}{aaaaabbbbbb.bib}
@misc{test,
title= "The title",
howpublished= "Publisher"
}
\end{filecontents*}
\documentclass{IEEEtran}
\usepackage{etoolbox}
\patchcmd{\thebibliography}{\section*{\refname}}{}{}{}

\begin{document}
\cite{test}
\bibliographystyle{IEEEtran}
\bibliography{aaaaabbbbbb}

\end{document}

enter image description here

Since IEEEtran.cls automatically adds an entry for the references in the ToC, you might also be interested in suppressing this entry (after all, there's no section for the references); in this case, you will also have to add

\patchcmd{\thebibliography}{\addcontentsline{toc}{section}{\refname}}{}{}{}
12

I think something easier would be \renewcommand\refname{}

  • 3
    The problem with this approach is that if \tableofcontents is used, then an odd entry with no title, but page number, is added to the ToC. – Gonzalo Medina Sep 10 '13 at 19:01
  • 5
    Moreover, space-wise, a section will still be set, perhaps leaving an unwanted (large) vertical gap between text and references. – Werner Sep 10 '13 at 19:06
8

If you are using biblatex:

\defbibheading{bibliography}[\refname]{}
  • 3
    \printbibliography[heading=none] as in Apteryx's answer. Would be slightly nicer, I think. – moewe Aug 8 '18 at 14:31
8

If you don't mind using biblatex instead of bibtex, you could simply use the following: \printbibliography[heading=none].

Dependencies:

  • biblatex
  • biblatex-ieee (for the IEEE bibliography style)

Here's a minimal example:

\documentclass{article}
\usepackage[style=ieee]{biblatex}
\addbibresource{refs.bib}

\begin{document}

\section{Some section}
Some text \cite{KandR}.

\printbibliography[heading=none]

\end{document}

For the sake of completeness, here is the content of the refs.bib file used:

@BOOK
  {KandR,
   AUTHOR    = {Kernighan, Brian W. and Ritchie, Dennis M.},
   TITLE     = {The C Programming Language Second Edition},
   PUBLISHER = {Prentice-Hall, Inc.},
   YEAR      = 1988
  }

After compiling the document with latexmk -bibtex -pdf, the result should look like this:

Result

  • Give me a example, because this did not work for me. – Anderson Jul 31 '15 at 19:12
  • 2
    I'm sorry, it seems this option is only available using biblatex instead of bibtex. I will update my answer with this information and a basic usage example. – Apteryx Aug 2 '15 at 17:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.