7

I have been trying for a few days now to get Icelandic characters. I've installed the cm-super font package and I'm using MiKTeX 2.9 on a Windows 8 Lenovo yoga btw.

Anyways I've made sure that icelandic.ldf and icelandic.sty are in the directory \MiKTeX 2.9\tex\generic\babel\.

The line \DeclareOption{icelandic}{\input{icelandic.ldf}} is in the file \MiKTeX 2.9\tex\generic\babel\babel.sty and I have the file ishyph.tex in the directory \MiKTeX 2.9\tex\generic\hyphen\.

I can't find any other dependency that I'm missing. I've made sure that all these things are selected in the MiKTeX option thing and I've also refreshed FNDB and Updated Formats after each change I've made. So I deduced that my error is in the document rather than in the dependencies.

\documentclass{article}
\usepackage[icelandic]{babel}
\usepackage[T1]{fontenc}
\selectlanguage{icelandic}
\begin{document}
I want these letters in amsart: þÞæÆöÖáÁíÍéÉúÚóÓýÝðÐ (I know I can get æ with \ae but that's useless without the others).
\end{document}

This works btw it is displayed correctly no problem. The problem is that I think I need my document class to be amsart (I'm using LaTeX for Linear Algebra homework) and it seems that AMS doesn't support icelandic. Is there any workaround or something I can do?

What I need to be able to do is make augmented matrices and that's about it. The way I'm doing it atm is adding this:

\makeatletter
\renewcommand*\env@matrix[1][*\c@MaxMatrixCols c]{%
  \hskip -\arraycolsep
  \let\@ifnextchar\new@ifnextchar
  \array{#1}}
\makeatother

to the front of my document and then using syntax like for example this:

$$
\begin{bmatrix}[cccc|c]
  a_{11} & a_{21} & \cdots & a_{n1} & b_{1} \\
  a_{12} & a_{22} & \cdots & a_{n2} & b_{2} \\
  \vdots & \vdots & \ddots & \vdots & \vdots \\
  a_{1n} & a_{2n} & \cdots & a_{nn} & b_{n} \\
  \vdots & \vdots & \ddots & \vdots & \vdots \\
  a_{1m} & a_{2m} & \cdots & a_{nm} & b_{m}
\end{bmatrix}
$$

I don't know how it works but it works except I don't have icelandic characters. If I can get the characters in amsart or the matrices in article I'm happy.

  • 3
    You're missing the \usepackage[utf8]{inputenc} declaration. Be sure your file is UTF-8 encoded and change article into amsart. That's all. – egreg Sep 11 '13 at 16:40
  • 2
    For your matrix modifications, you do not necessarily need amsart, article with \usepackage{mathtools} or even \usepackage{amsmath} should suffice. Please do not use $$..$$. There is no need for \selectlanguage{icelandic}, as the last language passed to babel as an option is automatically set as main language for the document. – moewe Sep 11 '13 at 16:56
6

This works, provided the file is saved as UTF-8

\documentclass{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[icelandic]{babel}
\begin{document}

\begin{verbatim}
I want these letters in amsart: þÞæÆöÖáÁíÍéÉúÚóÓýÝðÐ (I know
I can get æ with \ae\ but that's useless without the others).
\end{verbatim}

I want these letters in amsart: þÞæÆöÖáÁíÍéÉúÚóÓýÝðÐ (I know
I can get æ with \ae\ but that's useless without the others).

\end{document}

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.