3

I am trying to use LuaLatex for printing plots (as PdfLaTeX doesn't have enough memory) but I have a problem with it. I am using TeXLive 2013 with TeXMaker.

I was trying to compile a file once with LuaLaTeX and some errors were shown. I managed to compile that file using PdfLaTeX, however now that I need to use LuaLaTeX again, the same errors are shown with every file I am trying to compile, although they don't have any relation to the first file.

I have tried deleting the luatex-cache folder from C:\texlive\2013\texmf-var, however the problem persists.

Errors I got:

! String contains an invalid utf-8 sequence. \DeclareTextCompositeCommand{\"}{LGR}{

! String contains an invalid utf-8 sequence. \accdialytika \DeclareTextCompositeCommand

The MWE:

\documentclass[10pt,a4paper]{report} 
\usepackage[english,greek]{babel} 
\usepackage[utf8]{luainputenc} 

\begin{document} 
\latintext{Hello!} 
\end{document}

closed as off-topic by Joseph Wright Sep 14 '13 at 18:47

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Welcome to TeX.SX! May you please inform the errors? – user13907 Sep 12 '13 at 9:30
  • 1
    are all your files encoded as utf8? You may press on file - save as and change the encoding. Just a guess, but easy to try. – LaRiFaRi Sep 12 '13 at 9:41
  • 1
    And please show as a minimal working example which shows your problem. Are you loading the package fontenc? – LaRiFaRi Sep 12 '13 at 9:43
  • 2
    @whirlwind Don't load luainputenc, that's all. – egreg Sep 12 '13 at 10:26
  • 2
    @whirlwind luainputenc is only for compatibility with old documents; LuaTeX accepts by default UTF-8 input, there's no need of any special package for the input encoding. Update your TeX distribution. However, a bug has been planted in the last version of greek.ldf and the \fi on line 73 should be removed. – egreg Sep 12 '13 at 11:40