7

The biblatex \footcite command always moves points or commas, that originally appeared after \footcite, before the footnote number. For example, I have:

\documentclass[oneside]{scrbook}
\usepackage[english,ngerman]{babel}
\usepackage[babel,english=american,german=quotes]{csquotes}

\usepackage[bibstyle=authoryear, autocite=footnote, citestyle=authoryear-icomp, 
urldate=long, abbreviate=false, dateabbrev=false, backend=biber]{biblatex}
\usepackage[babel,english=american,german=quotes]{csquotes}

\begin{document}

In my text \enquote{I have a quote}\autocite{Author2008}, which 
cites \enquote{even more}\autocite[S.~76]{Author2005}, and then
just a normal footnote citation\autocite{Author2010}, and then it 
finishes here \enquote{with another quote}\autocite[S. 90]{Author2009}.

\end{document}

This results in:

(N.B. the order of footnote number and commas/dots now being reversed): enter image description here

However, I want it the order I originally typeset in the latex document, that is commas/dots before the number:

In my text "I have a quote"¹, which cites "even more"², and then just a normal footnote citation³, and then it finishes here "with another quote"4.

How can I stop biblatex from reverting the order of punctuation if there is a comma or dot after the \footcite?

5
  • I am a little curious about why you want to change this behaviour. – Martin - マーチン Sep 14 '13 at 19:45
  • It simply looks more natural to me, at least in German ;-) In my opinion, something like a comma marks the beginning of a new part of a sentence, that is, has nothing to do with the original quotation I am referring to. That's why I want "a quote like this"¹, instead of "like this",² -- because my quotation is not about the comma but about what comes before. However, if you have any "official" standards document about this should actually be done in German, I'd be happy to know about (I know in American/British English it seems to be handled somewhat differently). – nachtigall Sep 15 '13 at 1:18
  • I understand exactly what you want and originally i was thinking the same. However, citing is usually text depending (i am writing in German too), that is why no official documents may be found. The way you want to cite is footnote related and i found it most convenient to apply the same here. Usually the citation appearing at the end of a (half) sentence, refers to the whole sentence, which should be completed before. If you use direct citations implied like "this", inline citations like [1] shall be applied. – Martin - マーチン Sep 15 '13 at 21:09
  • 1
    I just found this, unfortunately i have not this particular book at home, but i think it is somehow trustworthy (in German): korrekturen.de/forum.pl/md/read/id/48557/sbj/… – Martin - マーチン Sep 15 '13 at 21:19
  • Note that British style guides also typically want the footnote marker before the punctuation mark. I think biblatex's configuration is somewhat US-centric in this matter. It is a shame that this requires setting autopunct=false since other aspects of this facility are useful. It just needs slightly more fine-grained control. – cfr Jan 8 '14 at 12:30
7

Use the option autopunct=false.

\documentclass[oneside]{scrbook}

\usepackage[english,ngerman]{babel}
\usepackage[babel,english=american,german=quotes]{csquotes}

\usepackage[style=authoryear-icomp, autocite=footnote, autopunct=false, 
    urldate=long, abbreviate=false, dateabbrev=false, backend=biber]{biblatex}

\usepackage{filecontents}

\begin{filecontents}{\jobname.bib}
@misc{A01,
  author = {Author, A.},
  year = {2001},
  title = {Alpha},
}
@misc{B02,
  author = {Buthor, B.},
  year = {2002},
  title = {Bravo},
}
@misc{C03,
  author = {Cuthor, C.},
  year = {2003},
  title = {Charlie},
}
\end{filecontents}

\addbibresource{\jobname.bib}

\begin{document}

\null\vfill% just for the example

In my text \enquote{I have a quote}\autocite{A01}, which 
cites \enquote{even more}\autocite[S.~76]{B02}, and then
just a normal footnote citation\autocite{C03}, and then it 
finishes here \enquote{with another quote}\autocite[S. 90]{A01}.

\end{document}

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.