how does one remove bookmarks from a LaTeX generated pdf file?

I wrote the article in LaTeX. When submiting the .pdf to IEEE eXpress for checking, I get the error:

file contains bookmarks.

Any ideas how to solve it?

I already tried:

  • 8
    There is no point in using hyperref, because links seems to be forbidden either according to the "PDF Specification for IEEE Xplore". Commented Sep 14, 2013 at 13:49
  • 3
    Try with \hypersetup{bookmarksdepth=-2} as in How to temporarily disable PDF bookmarking?
    – Werner
    Commented Sep 14, 2013 at 13:51
  • Welcome to TeX.SX! You might have a look on our our starter page if you wish to familiarize yourself further with our format. Commented Sep 14, 2013 at 13:53
  • @HeikoOberdiek Perhaps it does not apply to IEEE Xplore, but the hyperref package is used for PDF/X. A PDF/X document has no bookmarks or hyperlinks, so hyperref is used in its draft mode, without bookmarks etc. What hyperref does: It provides code for automatic encoding change in PDF metadata, and also supports part of the PDF info catalog.
    – user139954
    Commented Apr 17, 2018 at 21:41

5 Answers 5


Option bookmarks can only be given at package loading time. Setting it later with \hypersetup will give the warning:

Package hyperref Warning: Option `bookmarks' has already been used,
(hyperref)                setting the option has no effect on input line 3.

Bookmarks can be disabled, if bookmarks=false is given to \usepackage:




can be tried, before hyperref is loaded by another package or class and option bookmarks is not explicitly set by the other package or class.

If the requirements of "PDF Specification for Xplore" are holding, then you should not use hyperref at all, because links are not allowed either. Thumbnails can be added by package thumbpdf; the PDF file can be converted by pdfopt of ghostscript for fast web view.

  • 1
    Thank you this saves my day! multiple errors after IEEE eXpress check were fixed just by using bookmarks=false!
    – iamaziz
    Commented Nov 15, 2016 at 13:53
  • 4
    Sometimes, you need to put the order \PassOptionsToPackage{bookmarks=false}{hyperref} at the very beginning of the document (first line) to pass the check.
    – ccy
    Commented Feb 9, 2018 at 12:22
  • 1
    \PassOptionsToPackage{bookmarks=false}{hyperref} worked for me!
    – manooooh
    Commented May 20, 2019 at 21:42

An alternative is to use Draft mode


The PDF created in Overleaf with the document class


passed the IEEE eXpress checking


Or just try any viewer with edition options, like the free version of PDF Exchange Viewer, with which you can remove bookmarks from any unprotected pdf file.

  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post.
    – jub0bs
    Commented Jan 12, 2014 at 13:25
  • 2
    @Jubobs This might IMHO answer the question. The fact that some PDF viewers are able to remove the bookmarks is valuable here, and it might be an option for the OP.
    – yo'
    Commented Jan 12, 2014 at 14:52
  • @tohecz I agree, but I think it's a bit short to warrant a full-blown TeX.SE answer. It would have been more appropriate as a comment.
    – jub0bs
    Commented Jan 12, 2014 at 15:18
  • 1
    @Jubobs Quite certainly, it is not of the quality we're used to. However, I think that it has its value nevertheless, and I don't really see how could it be expanded.
    – yo'
    Commented Jan 12, 2014 at 15:25

I just found out a simple solution. "Print" your PDF, and in the option for "Printer", select the option "Microsoft print to PDF", and it will remove the hyperlinks and bookmarks. I suppose there should be similar options for Mac or Linux users.enter image description here

  • This might be true, but printing it this way increased the file-size for a simple two-page, text-only document from 75kB to almost 1MB, so no, this is not an option. Commented Aug 21, 2017 at 15:29

For some reason, none of the proposed solutions (e.g. \PassOptionsToPackage{bookmarks=false}{hyperref}, \hypersetup{draft}, ...) worked for me. It might have something to do with the libraries I have used or including PDFs as graphics.

Anyways, I ended up using the following command:

pdftk A=paper.pdf cat A1-end output paper-nobookmarks.pdf

which is pretty much a command-line equivalent of Kristada673's "print to PDF" solution. The IEEE eXpress test passed after that.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .