I am trying to use BibTeX on my Mac to produce some simple citation references.

I copied some example code from online tutorials into a .tex file and a .bib file. The first LaTeX run on TeXShop gives me a PDF without any references. An .aux file is generated and valid. But I am failing at the next step. Normally BibTeX should run on the recently produced .aux file and generate an .bbl file which LaTeX uses in his second compile run, right? It doesn't. There is no .bbl file produced and I am getting no messages about it. It appears that the step "BibTeX runs on the .aux file to generate an .bbl file" never starts.

I am using TeXShop on Mac OS. Any ideas? How do I even start the BibTeX thing on Mac OS? When I'm working on Windows in TeXnicCenter it does this step by itself.


2 Answers 2


TeXShop doesn't do the BibTeX run by itself.

First step: run LaTeX

Here's how the window should appear

enter image description here

Second step: choose BibTeX

Choose BibTeX from the dropdown menu

enter image description here

Third step: run BibTeX

Click on the "Typeset" button (or hit Command-T)

enter image description here

Then return to LaTeX and compile again.

You can run BibTeX when you need it, you don't need it to be run at each LaTeX run; only when references are added or removed.

  • There's also the keyboard shortcut SHIFT+CMD+B, which doesn't require changing the compiler in the dropdown menu.
    – Adam Liter
    Commented Jan 24, 2014 at 0:14
  • @egreg Shouldn't also the option Biber appear on that drop down menu? Also, is there an automated way to do this?
    – Jim
    Commented May 8, 2022 at 3:11

I was struggling with this specific issue several days. I found it at last: some LaTex compilers doesn't have default defined bibliography style. So user should specify the style be using command



and replace "STYLE-FILE" with the desired style file with extension ".BST" for example if you download the ASME author templates in:


you will see that these commands in the tex file "asme2e.TEX":



So if you look at the folder you will see the style file: asmems4.BST and also bibliography file: asme2e.BIB. The reason my compiler doesn't make .BBL file because I just mistakenly cleared the style line because they are not written close to each other. So you may do the same mistake of mine! then the poor compiler couldn't make the .BBL file! :D I was in time pressure of submitting the paper and I just created the .BBL file myself! But after the releasing from the stress I found this simple solution!

Enjoy :)

  • It's not clear that this answer the question. Based on the information given by the OP, it seems that the OP was not running bibtex.
    – Adam Liter
    Commented Jan 24, 2014 at 0:10
  • 1
    No “LaTeX compiler” has a default bibliography style. Some classes do, but it's the exception rather than the rule. A \bibliographystyle command in the document is usually necessary.
    – egreg
    Commented Jan 24, 2014 at 0:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .