9

I do not want different margins on even and odd sides, I just want the usual page setup from the amsart package. However, consider:

\documentclass{amsart}
\usepackage{geometry}
\usepackage{lipsum}
\begin{document}
\lipsum[1-20]
\end{document}

compiling this with pdflatex gives different margins on odd and even sides. I think the problem is the combination of the amsart and geometry packages. If I do not use the geometry package it works fine. If I use \documentclass{article} it also works fine.

6

If you use the package layout you get a picture of the dimensions used by the amsart for laying out the page. The following document reproduces that layout using the geometry package:

\documentclass{amsart}    

\usepackage[marginratio=1:1,height=584pt,width=360pt,tmargin=117pt]{geometry}
\usepackage{lipsum}

\usepackage{layout}

\begin{document}
\layout
\lipsum[1-20]
\end{document}

In particular, the height and width specifications correspond to the \textheight and \textwidth produced by amsart. The marginratio makes the marigns even, and tmargin moves the text down appropriately.

The value of tmargin was obtained as follows. layout reports for amsart that \topmargin=22pt. To convert this to tmargin I added 1in = 72pt plus headheight=14pt to the 22pt. However, the resulting layout reported a \topmargin of 21pt, so I bumped the result up by 1pt, to get the required value. The geometry documentation says

tmargin has nothing to do with \topmargin

but the package only provides tmargin to set the corresponding space.

All the above is assuming US latter paper. The amsart class sets:

\headheight=8pt \headsep=14pt
\footskip=12pt
\textheight=50.5pc \topskip=10pt
\textwidth=30pc
\columnsep=10pt \columnseprule=0pt
\marginparwidth=90pt
\marginparsep=11pt
\marginparpush=5pt

and has

\DeclareOption{a4paper}{\paperheight 297mm\paperwidth 210mm
  \textheight 54.5pc }
\DeclareOption{letterpaper}{\paperheight 11in\paperwidth 8.5in }

So if you specify a4paper option then a different \textheight is used. Again the layout package will report it for you.

  • Thanks! This seems to work. How did you calculate tmargin=117pt from the output of the layout package? – Håkon Hægland Sep 18 '13 at 9:30
  • It seems that if I use the a4paper option (\documentclass[a4paper]{amsart}) I get height=632pt instead of height=584pt.. – Håkon Hægland Sep 18 '13 at 9:55
  • Replies now included in my answer. – Andrew Swann Sep 18 '13 at 10:06
5

The amsart class uses equal sized margins by default and the twoside option. However, When geometry realizes that the twoside option is in force, it uses a “2:3” ratio for the margins.

The text width set by amsart is 360pt independently on whether A4 or Letter paper is used. With geometry, instead, you get 430pt for Letter paper and 418.25pt for A4 paper.

If all you want is a larger text width, you can say

\documentclass{amsart}
\usepackage[
  hmarginratio={1:1},     % equal left and right margins
  vmarginratio={1:1},     % equal top and bottom margins
  textwidth=400pt,        % new text width
  heightrounded,          % always useful
  %bindingcorrection=5mm,  % binding correction
]{geometry}
\usepackage{lipsum}
\begin{document}
\lipsum[1-20]
\end{document}

Don't specify oneside in the options for amsart, as this will affect the way the headers are set. The vmarginratio option is needed if you want the same look as amsart's default, with equal upper and lower margins (header and footer not included).

2

You can use the parameters of the package geometry to remove the difference between even and odd pages. For instance, the following package declaration

\usepackage[hmarginratio=1:1]{geometry}

aims at defining the ratio between the different margins.

You can use hmarginratio or vmarginratio

Also,

\usepackage[top=4cm, bottom=3cm, left=3cm, right=3cm]{geometry}

permits to set the margins.

  • Thanks! It seems that hmarginratio=1:1 gives a different page layout than that used by the amsart package.. For instance, it gives height=556pt and width=430pt.. Compare with the answer given by Andrew Swann. – Håkon Hægland Sep 18 '13 at 10:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.