21

I use the authoryear style in biblatex, and when I do for instance \cite{bauman2000}, I get:

Bauman 2000

But I would like to add a comma between the author and the year, in order to have

Bauman, 2000

Is there a simple command to get this change ?

  • Welcome to TeX.SX! – egreg Sep 19 '13 at 10:20
  • Welcome to this site. I hope you will have a wonderful time here. – Masroor Sep 19 '13 at 10:38
32

The space between the name and the year is controlled by the macro \nameyeardelim. So you have to redefine it:

\renewcommand*{\nameyeardelim}{\addcomma\space}

Here a small example:

\documentclass[]{article}
\usepackage[style=authoryear]{biblatex}
\addbibresource{biblatex-examples.bib}
\renewcommand*{\nameyeardelim}{\addcomma\space}
\begin{document}
\cite{companion}
\end{document}

The default definition can be found in the file biblatex.def. There are other useful definitions are also done.

  • 3
    Thanks it works !! Is there a way to flag this question as "resolved" ? – Leo Sep 19 '13 at 11:47
  • @Leo: Yes, there is a checkmark under the arrows. I am glad that it helps. – Marco Daniel Sep 19 '13 at 11:57
  • 2
    The number of small changes I've had to add to biblatex in order to make it produce standard citations is amazing.. Makes me wonder if this is the best option anyway. – Doggie52 Mar 10 '15 at 13:52
  • After adding the above line in my code, I got "... command already defined ..." error. I then edited corresponding line in the default definition file biblatex.def (in my system it is located in /usr/share/texlive/texmf-dist/tex/latex/biblatex/biblatex.def). Then it worked. Editing this file may require permission. – Sisay Chala Nov 4 '15 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.