I am using Sweave to generate a pdf from a .Rnw file. I added a new build configuration in Kile using Kile's build-configuration settings.

Settings > Tools > Build

OS is Windows 7. How do I fix this error? I don't see an option for specifying log file. After setting this, compilation is working fine, but the "log and messages" pane in Kile, at the bottom is not able to show the compilation status message and says:.

"Cannot open log file; did you run LaTeX?"

The new build configuration is:

COMMAND:: C:\Program Files\R\R-2.15.1\bin\x64\R.exe

OPTIONS:: CMD Sweave --pdf %source


Type (Run Outside of Kile)

Class (LaTeX)

Source Extension (Rnw)

Target Extension (tex)

State (Editor)

2 Answers 2


It is not really an error. At the end of some build operations (I believe those of Class LaTeX) Kile scrapes the log file and automatically decides if it should rerun the previous command and tells you about warnings, errors, and bad boxes. Presumably after running R.exe there is either not a log file or Kile is unable to strip the extensions and get to the log file. No matter the cause, it is not a big deal. I think if you change the Class to Compile or untick "automatically run additional tools" you should be able to make the warning go away.


Does KILE compile other simple documents? I am asking that because KILE is supposed to work with KDE (e.g., Kubuntu, or generally in GNU Linux type OS).

Please, try to see if your code runs with other TeX editors like TeXStudio or Texmaker.

  • Kile compiles other documents. My code runs by executing directly from the windows cmd prompt. Sep 23, 2013 at 21:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .