6

I am trying to increase the baselineskip for every chapter except the titlepage. I am using setlength to change its value but it has no effect. Any help would be great. Following is my main file.

\documentclass[11pt, a4paper, twoside, openright]{memoir}

% \includeonly{./chapters/conclusion/conclusion}

\usepackage{graphicx} % For inserting graphics in the page
\usepackage{epstopdf} % For automatically converting eps images to pdf while using pdflatex
\usepackage{dblfloatfix} % For using a "b" as placement specifier for a page wide image
\usepackage{fixltx2e} % For ensuring correct image numbering when we use \figure*
\usepackage{mathtools} % For using mathematics environments
\usepackage{amsfonts} % For using text formatting in equations eg \mathbf
\usepackage{algorithm} % For wrapping algorithmic environment to produce a floating    environment.
\usepackage{algorithmic} % For using algorithmic environment
\usepackage{threeparttable} % For adding footnotes to the table
\usepackage{subcaption} % For putting multiple figures within a single figure environment
\usepackage{tikz} % For drawing

\graphicspath{{chapters/SASNN/img/}{chapters/GSNN/img/}{chapters/literature/img/}{chapters/intro/img/}{chapters/conclusion/img/}{garnish/cover/}}

\setsecnumdepth{subsubsection}

% To ensure equal margin for odd and even pages
\setlength{\oddsidemargin}{15.5pt}
\setlength{\evensidemargin}{15.5pt}

% Increase line spacing
\setlength{\baselineskip}{24pt plus 1pt minus 1pt}

\begin{document}
% title page
\input{./garnish/cover/cover}

% abstract
\begin{abstract}
\input{./garnish/abstract/abstract} % We use input because usage of include causes an extra bank page to be added.
\end{abstract}

\mainmatter    
\include{./chapters/intro/intro}
\include{./chapters/literature/literature}
\include{./chapters/GSNN/gsnn}
\include{./chapters/SASNN/sasnn}
\include{./chapters/conclusion/conclusion}

\backmatter
\include{./garnish/pub/pub}

\bibliographystyle{plain}
\bibliography{../../../Bibliography/Bibtex/SNN}
\end{document}

UPDATE: I tried \linespread also but that doesn't work either.

1
  • Thanks for replying.......Moving $\setlength{\baselineskip}{24pt plus 1pt minus 1pt}$ to after \mainmatter worked for me....
    – Shaun
    Sep 21, 2013 at 15:37

1 Answer 1

7

The use of memoir's own spacing commands (based on setspace) is my recommendation since it doesn't doublespace things that really shouldn't be doublespaced, and doesn't suffer from the above \baselineskip change, which won't work as soon as a font size change is made. See this FAQ. Compare the following example:

\documentclass[openany, 11pt, a4paper, twoside]{memoir}

\usepackage{lipsum}

\begin{document}

\begin{abstract}
\lipsum[1]
\end{abstract}

\DoubleSpacing%             <-- memoir command; comment and this line and uncomment the next...
\setlength{\baselineskip}{24pt plus 1pt minus 1pt}% <-- ... in order to see the difference

\mainmatter
\chapter{a}

\footnote{\lipsum*[2]}%
\large %                   <-- things like this will cause problems (and they are often implicitly set by other document commands)
\lipsum[1]

\backmatter

\chapter{b}\lipsum[1]

\end{document}

memoir in fact offers a whole suite of spacing commands; consult the manual (§ 3.3.2) for the many options.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .