1

I'm using TeXworks to compile a paper, but can't figure out how to include a bibliography page with the author-date format style. I want to refer to papers in the format (Author, YYYY) and in the bibliography to have author, then year. I was previously using \bibliographystyle{ieeetr} and my document was compiling just fine.

Now, I've downloaded a bunch of packages following David Fussner's instructions for the biblatex-chicago package, but for the life of me I can't make my document run. I have a bunch of other packages in the preamble that may be conflicting with biblatex-chicago (I've added them as I've needed to do things with figures, tables, footnotes at the end of the document, etc). Here's my preamble:

\documentclass[12pt]{article}
%
\usepackage{amssymb}
\usepackage{amsfonts}
\usepackage{amsmath}
\usepackage[nohead]{geometry}
\usepackage[singlespacing]{setspace}
\usepackage[bottom]{footmisc}
\usepackage{indentfirst}
\usepackage{endnotes}
\usepackage{graphicx, subfigure}
\usepackage{rotating}
\usepackage{booktabs}
\usepackage[tableposition=top]{caption}
\usepackage{placeins}
\usepackage{afterpage}
\usepackage{multirow}
\usepackage{hyperref}
\usepackage{color, colortbl}
\definecolor{Gray}{gray}{0.9}
\usepackage[justification=centering]{caption}
\usepackage{array,longtable,calc}
\usepackage{arydshln}
%
\newcommand{\ra}[1]{\renewcommand{\arraystretch}{#1}}
%
\usepackage[margin=65pt,font=small,labelfont=bf,justification=raggedright,singlelinecheck=false]{caption}
\DeclareGraphicsExtensions{.eps,.jpg}
\usepackage{etoolbox}
\usepackage[authordate,backend=biber]{biblatex-chicago}
\bibliography{newreferences.bib}

I'm citing using \cite{Glomm1994}and at the end I have:

\newpage
\printbibliography

I'm getting all sorts of errors. Once it actually ran, but with no bibliography page. I need some logic to follow when adding the packages necessary for Chicago style bibliography. There are so many options out there I no longer know what I'm doing.

Any help would be appreciated. I have a deadline and I've dedicated too much time on something that should be simple.

  • Welcome to the side. Please provide a minimal working example. (P.S. I'm going to bed now.) Also, you can highlight code by indenting each line by 4 spaces or by clicking on the botton with the curly braces above the editing window. – Svend Tveskæg Sep 22 '13 at 2:08
  • 2
    If you write /cite{Glomm1994} you will not get a citation; macro begin with a backslash---not a frontslash. – Svend Tveskæg Sep 22 '13 at 2:08
  • For guidance on how to use biblatex, see What to do to switch to biblatex? and biblatex for idiots, specifically for biblatex-chcago see Get biblatex-chicago working. From what I can see, the list of packages you load should not conflict with biblatex-chacago (you load caption twice though). If after reading the post above you still have trouble compiling, delete all temporary files, recompile, edit your question and post the relevant errors here. – moewe Sep 22 '13 at 6:53
  • Fixed some repeated calls for different packages, there is no need to load booktabs or caption more times than one call of \usepackage{...}. Try to check if the order/sequence of calls inside your preamble is right, then re-compile. If the problem persist, then you can focus only on the main error generated by the bib. and not the preamble. – TheVal Sep 22 '13 at 19:48
  • 5
    This question appears to be off-topic because it is due to an out-of-date installation. – Andrew Swann Sep 24 '13 at 9:43