3

I'm using biblatex with biber and an authoryear style for my bibliography. My main language is french, but I have different languages in my bibliography (so I load \usepackage[english, french]{babel}. I would like biblatex to print bibliography items hyphenated according to their hyphenation field (e.g. no space before double punctuation and question marks), but always with french-style quotation marks. When I use \usepackage[babel=hyphen]{biblatex}, biblatex uses the hyphenation language (e.g.: english) quotation marks, but doesn't seem to use other rules (such as no space before double punctuation and quotation marks). That's exactly the opposite of what I'm looking for. When I use \usepackage[babel=other]{biblatex}, biblatex does use the right hyphenation rules, but still uses the foreign language quotation marks, and also uses the foreign language version of some strings (e.g. 'in' or 'cit. on').

I've looked around quite a lot but couldn't find a solution to this problem. Any idea?

EDIT: here is a MWE:

\documentclass{article}
\usepackage[T1]{fontenc}
\usepackage[english, french]{babel}
\usepackage[autostyle=true]{csquotes}
\usepackage[citestyle=authoryear-comp, bibstyle=authoryear, natbib=true, babel=hyphen]{biblatex}

\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@ARTICLE{agnew_iv._1987,
  author = {Agnew, John},
  title = {{IV.} Place anyone? A comment on the {McAllister} and Johnston papers},
  journal = {Political Geography Quarterly},
  year = {1987},
  volume = {6},
  pages = {39--40},
  number = {1},
  month = jan,
  doi = {10.1016/0260-9827(87)90030-9},
  hyphenation = {english},
  issn = {0260-9827},
  shorttitle = {{IV.} Place anyone?},
  url = {http://www.sciencedirect.com/science/article/pii/0260982787900309},
  urldate = {2012-08-02}
}
\end{filecontents}

\addbibresource{\jobname.bib}

\begin{document}

 Some text.

 Some text, with a citation \citep{agnew_iv._1987}.

 And now a bibliography.

 \printbibliography
\end{document}

The output here is: input

I would like the same but with French "guillemets" (quotation marks).

  • Welcome to TeX.SX! Even though your question is quite clear, a MWE might help us. (e.g. What options do you load csquotes with?) Just to clarify: You do not only want to change the hyphenation, but also some punctuation behaviour, you do not, however, want to change the quotation marks? Is the punctuation behaviour to be changed in title/subtitle fields or everywhere for that particular entry (that is "in : Journal" vs "in: journal")? – moewe Sep 22 '13 at 10:10
  • Indeed, I should have provided a MWE, but I have to admit I was lazy ;-) csquotes is loaded with autostyle=true. I want to change hyphenation and punctuation behaviour (actually, I think you're right: only in the title, and some other fields like journal name, book title for @inbooks, etc.), but not the quotation marks, nor the localisation of workds like "in" etc. But for that last matter I can use tricks like \DefineBibliographyStrings. – Joël Sep 22 '13 at 10:21
  • Well, there is still time :-). It would be very helpful, if you could provide a MWE along with the desired output of some example entries, so we can see exactly what you want. (I for one, have still some trouble figuring out what exactly needs to be changed; the only thing babel=hyphen messed up in my test was spacing around colons in foreign language entries.) – moewe Sep 22 '13 at 10:30
  • @moewe I've added a MWE. – Joël Sep 22 '13 at 10:49
  • Fine! That is very weird indeed, I get the output « IV. Place anyone? A comment on the McAllister and Johnston papers ». (with French spacing), which is, I suppose, what you want. What version of biblatex/Biber are you using? – moewe Sep 22 '13 at 10:52
3

The problem actually comes from the autostyle=true option passed to csquotes. If you remove it, it works just as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.