5

I am using Texstudio 2.6. I enabled autocompletion of schemabloc package in the Texstudio Options. When I am typing in the document, autocompletion for package commands is not working? Can somebody resolve this one?.

1 Answer 1

8

Completion and syntax check is both based on so called cwl files, which contain the definitions of the commands. TXS ships with cwls for some frequently used packages but by far not for all. If there is no cwl for a package yet, TXS tries to create one by extracting the information from the TeX source of the package. By default these commands are marked as not to be used in autocompletion because some packages define commands in lots of variants which then would flood the completer. You can change this behavior by editing schemabloc.cwl. It's located in the settings folder. Short solution: Just delete the S after the command if you want to show it in the completer. If you want to know more, have a look at the description of the cwl format

n.b.: In most cases it is not necessary any more to explicitly enable the packages in the options because TXS tries to automatically load the cwl files when it encounters a usepackage command.

1
  • Thanks for your suggestion.. now autocompletion works perfectly ofter removing S.
    – K Prakasam
    Oct 3, 2013 at 8:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .