2

While I can work (now, after good help via SE) without any problem using the Biblatex Oscola style with the book class, I'm not able to make it work with the memoir class:

The preamble

\documentclass[a4paper,english]{memoir}
\usepackage[utf8]{inputenc} 
\usepackage{newcent,textcomp}
\usepackage[english,latin]{babel}
\usepackage[style=british]{csquotes}
\usepackage[style=oscola]{biblatex}
\usepackage[titles]{tocloft}

returns an error:

|8 error| LaTeX Error: Option clash for package tocloft.

And when I comment out the eighth line, I get

Undefined control sequence. \newindex {trash}{tdx}{tnd}{Miscellaneous} \begin{document}

It'd be great if you could help. (NB: I'm wondering, moreover, whether -- for a PhD thesis (no maths involved) -- you'd advise for or against the memoir and book classes.

The problem seems to be different as was the case in Problem with memoir and biblatex together

Thank you.

  • 4
    The error message is not helpful in this case, but look at oscola.bbx: you need to load package index or imakeidx. (I recommend the latter.) Alternatively, you could add to your preamble: \newcommand{\newindex}[4]{} That is after you remove the line \usepackage[titles]{tocloft}. The functionality of this package is incorporated into the memoir class anyway. – jon Sep 23 '13 at 3:11
  • 1
    Maybe you should have a look at the more rigid but well designed classes like suftesi, ClassicThesisor github.com/suchow/LaTeX-template-for-Harvard-dissertation – DG' Sep 23 '13 at 10:10
  • @DG' thank you for the suggestions, suftesi looks good, but I like the standard book class. The Harvard PhD template, then, seems not to get along too well with the oscola biblatex style - and I do have to use the latter. I've also tried www-h.eng.cam.ac.uk/help/tpl/textprocessing/ThesisStyle but decided against it. – Jonas Sep 23 '13 at 11:56
  • @Jonas if you like the standard book class (or memoir for that matter), use it! With the right packages you will be able to do whatever you are needed to, in order to meet the requirements for your thesis. – DG' Sep 23 '13 at 15:14
  • @jon As your solution works very well, it would be quite nice to have it as an answer. – moewe Sep 24 '13 at 18:24
5

The long-term solution will be for the oscola style to take greater care if the user uses the memoir class, which tricks oscola into thinking you have loaded the index package. For now, if you stick with memoir (no reason you shouldn't), you have a few options.

If you are going to do indexing eventually, the best thing is to add

\usepackage{imakeidx}

which is definitely one of the better indexing packages.

If you don't care about indexing, then you could do either:

\DisemulatePackage{index}

or (possibly less advisably):

\newcommand{\newindex}[4]{}

Here's a complete minimal file:

% Note the difference between memoir and (say) report
% \documentclass[a4paper,english]{report}
\documentclass[a4paper,english]{memoir}

\DisemulatePackage{index}
% \usepackage{index}% <-- you could even load it now

% Or just load imakeidx (can still \DisemulatePackage if so inclined)
% \usepackage{imakeidx}
% Or:
% \newcommand{\newindex}[4]{}

\usepackage[utf8]{inputenc}
\usepackage{newcent,textcomp}
\usepackage[english,latin]{babel}
\usepackage[style=british]{csquotes}
\usepackage[style=oscola]{biblatex}
\begin{document}
words.
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.