2

I use a distribution for MikTeX for Windows and TikzEdt (http://www.tikzedt.org/).

How to enable support for Russian language in TikzEdt?

This code does not work:

\begin{tikzpicture}
  \node (h) at (1,1) {Привет};
  \node (w) at (3,3) {мир};
  \draw (h) edge (w);
\end{tikzpicture}

I tried to change the configuration, but it did not help.

%\documentclass{article}
\documentclass{extarticle}
\usepackage[T2A]{fontenc}
\usepackage{pscyr}
\usepackage[cp1251]{inputenc}
\usepackage[english,russian]{babel}
%
\usepackage{tikz,amsmath, amssymb,bm,color}
\usepackage[active,tightpage]{preview}
\usetikzlibrary{shapes,arrows}
% needed for BB
\usetikzlibrary{calc}

\PreviewEnvironment{tikzpicture}

How to enable support for Russian letters in TikzEdt 0.2?

enter image description here

closed as unclear what you're asking by jubobs, Kurt, Claudio Fiandrino, Benedikt Bauer, Werner Oct 15 '13 at 14:55

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    If I remove pscyr, that I don't have, I see no problem. – egreg Sep 23 '13 at 8:14
  • \documentclass{extarticle} \usepackage[utf8x]{inputenc} \usepackage[english,russian]{babel} Does not work! – Youra_P Sep 23 '13 at 13:23

Browse other questions tagged or ask your own question.