9

I'm using the biblatex-chicago package to get my references in the author-year format, but I'm struggling with the citation styles. I'm using \autocite{cite key} modified using \renewcommand*{\nameyeardelim}{\addcomma\addspace} to be able to have a citation in parenthesis after providing a data figure (e.g. "increased by 5% (UNESCO, 2012)"). But I would also like to use \textcite{cite key} to cite a paper in the fashion 'according to Nash (1950)". Instead, I'm getting 'according to Nash1950" (the cite key in bold letters).

Is \textcite not compatible with biblatex-chicago? This citation style is supposed to look like Nash (1950). I've tried removing -chicago and running again, or using the harvard style. I also found a bibliography style (a .bst file) specific to the economics field that is a customized way to achieve citations in the format Nash (1950) so I tried using \bibliographystyle{econ_aer.bst} but that didn't work either.

Please help

MWE:

\documentclass{article}

\usepackage[backend=biber]{biblatex-chicago}
\renewcommand*{\nameyeardelim}{\addcomma\addspace}
\usepackage{filecontents}

\begin{filecontents}{\jobname.bib}
@misc{UNESCO2001,
  author = {UNESCO.},
  year = {2001},
  title = {Alpha},
}

@misc{Nash1950,
  author = {Nash, D.},
  year = {1950},
  title = {Game Theory},
}

\end{filecontents}

\addbibresource{\jobname.bib}

\begin{document}

According to \textcite{Nash1950}. data figure \autocite{UNESCO2001}.

\printbibliography

\end{document}
  • 3
    Have you tried \usepackage[backend=biber,authordate]{biblatex-chicago} or \usepackage[backend=biber,authordate,natbib]{biblatex-chicago}? – Mensch Sep 23 '13 at 23:38
  • 2
    If you are getting Nash1950 (in bold) in this example file, it sounds like you are not running the usual sequence of latex, biber, latex (or latex, bibtex, latex, latex depending on which backend option you use). – jon Sep 24 '13 at 0:54
  • Looks like adding natbib following Kurt's suggestion above did the trick. I appreciate the help!! – timbers Sep 24 '13 at 2:39
  • I voted on your answer, but I'm not seeing a green checkmark next to it... ?... I read the "How do you accept an answer?" doc. Sorry if I'm not doing it right. – timbers Sep 26 '13 at 15:21
7

To get a author-year format just add option authordate to the call of package biblatex-chicago. If you need some (not all!) functions used in package natbib add the option natbib to the call of biblatex-chicago. Do not use option natbib=true (see manual, page 3 for explanation)! You can't use package natbib and biblatex-chicago together.

More informations to biblatex-chicago you will find in the package documentation.

With the following MWE (with a little bit pretty printing) you should get what you want:

\RequirePackage{filecontents}
\begin{filecontents*}{\jobname.bib}
@misc{UNESCO2001,
  author = {UNESCO},
  year   = {2001},
  title  = {Alpha},
}
@misc{Nash1950,
  author = {Nash, D.},
  year   = {1950},
  title  = {Game Theory},
}
\end{filecontents*}


\documentclass{article}

\usepackage[%
  backend=biber
 ,authordate     % returns Nash (1950)
%,natbib         % make some functions of package natbib available
]{biblatex-chicago} % http://www.ctan.org/pkg/biblatex-chicago
\renewcommand*{\nameyeardelim}{\addcomma\addspace}
\addbibresource{\jobname.bib}


\begin{document}

According to \textcite{Nash1950}. data figure \autocite{UNESCO2001}.

\printbibliography

\end{document}

This will gave you the result:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.