I recently started using WinEdt 8.0 to tex up my papers, and when I typeset my files it opens up Adobe to view the Pdf version of my file.

However, I remember when I used to use WinEdt a while back (I forget the version), it would open the Pdf file within the WinEdt system itself, without opening Adobe.

Moreover, when it opened it from within the system it would bring me right to where my last edit was made in the file, where as now when it opens it with Adobe I have to start from the beginning each time.

So how can I change my preferences so that it doesn't open Adobe each time that I typeset my file? Thanks!

  • 3
    As far as I remember, WinEdt doesn't come with a built-in PDF viewer (as e.g. TeXShop does), but requires an external viewer to display PDFs. – NVaughan Sep 24 '13 at 3:27
  • 5
    WinEdt never had a built-in pdf viewer. You can change the viewer options (e.g. if the viewer should be opened automatically after the compilation and which viewer winedt should use) in options->execution modes. If you want a viewer with good forward and backward search: Use sumatra. Each version of Adobe is getting worser in this respect. – Ulrike Fischer Sep 24 '13 at 8:12

Just to summarize the comments into an answer.

WinEdt has never had a built-in PDF viewer. It interacts with the program associated with .pdf files.

Anyway, you can keep your favourite program to open .pdf files and tell WinEdt to interact with a different viewer. To do that, go to "Options" -> "Execution Modes" -> "PDF Viewer" and choose one of the "Alternatives".

enter image description here

If your viewer is not listed there, you can manually insert the full path of your viewer.

I strongly suggest SumatraPDF because it is the one which has the best implemented forward/inverse search functionality.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.