2

I am trying to conform to a bibliographic style that is close to "historian", but instead of the usual abbreviations in the bibliography, they want the words spelled out. So instead of this:

Turner, Nigel. Syntax. Ed. by James Hope Moulton. Vol. 3 of A Grammar of New Testament Greek. Edinburgh: T. & T. Clark, 1963.

This:

Turner, Nigel. Syntax. Edited by James Hope Moulton. Volume 3 of A Grammar of New Testament Greek. Edinburgh: T. & T. Clark, 1963.

I have tried the following, but it does not work.

\DefineBibliographyStrings{american}{%
namedash={---------},%
volumeof={of},
editor={Edited by},
translator={Translated by}
}
3

The language file historian.lbx (which is an alias of american, if you use another language you will have to do some language mapping first) contains all the language definitions for historian.

historian distinguishes between citations in footnotes (where a shorter, abbreviated form is employed) and the bibliography (a more verbose, not abbreviated style), you will find lines like this.

byeditor         = {{\ifbibliography{edited by}{ed\adddotspace}}{\relax}},%changed

If byeditor is printed in the bibliography "edited by" is inserted, in footnote citations just "ed.".

As a matter of fact, my version of the style prints "edited by" (unabbreviated) as you wanted.

For "volume", add this to the preamble

\DefineBibliographyStrings{american}{%
  volume           = {\ifbibliography{volume}{vol\adddot}},%changed
}

As you have not provided a comprehensive list of words you want not abbreviated, I will describe the process you can go through to change it yourself.

Locate historian.lbx (via kpsewhich historian.lbx) open it, then look for the abbreviated string appearing in your bibliography (maybe you can guess the strings identifier), be aware that dots will probably be transformed to \addot, spaces to \addspace/\addabbrvspace etc. (as we saw above), copy the definition into the preamble as done above, remove the part saying {\relax} (including the curly braces!) and change the string to whatever you want.

Another example: Suppose you want "edition" to display in the bibliography not just "ed.". Find the edition bisbtring in historian.lbx; here it is

edition          = {{\ifbibliography{ed\adddot}{ed\adddot}}{\relax}},% Changed

the changes you will have to apply are

edition          = {{\ifbibliography{ed\adddot}{ed\adddot}}{\relax}},% Changed
                                  modify this              |remove |

copy it to the preamble and modify it

\DefineBibliographyStrings{american}{%
  volume           = {\ifbibliography{volume}{vol\adddot}},%changed
  edition          = {\ifbibliography{edition}{ed\adddot}},% Changed
}

The MWE

\documentclass[a4paper,american]{article}

\usepackage{babel}
\usepackage[utf8]{inputenc}
\usepackage{lmodern}
\usepackage[T1]{fontenc}
\usepackage{csquotes}
\usepackage[style=historian,backend=biber]{biblatex}
\usepackage{hyperref}

\addbibresource{biblatex-examples.bib}

\DefineBibliographyStrings{american}{%
  volume           = {\ifbibliography{volume}{vol\adddot}},%changed
  edition          = {\ifbibliography{edition}{ed\adddot}},% Changed
}

\begin{document}
Ah\footcite{westfahl:space}
\parencite{coleridge}
\cite{companion}

\printbibliography
\end{document} 

yields enter image description here

Compare the footnote and bibliography entry; in particular "ed. Gary Westfal" vs. "edited by Gary Westfal"

2

There is an option for not using abbreviations when you load the package:

\usepackage[abbreviate=false]{biblatex}
  • You will find though the word "vol." is still abbreviated in the bibliography, so is edition (to "ed."); " Edited by" is not abbreviated but that was not abbreviated in the first place (with my version of the files). – moewe Sep 26 '13 at 4:21
  • No, those things are properly spelled out. Perhaps there is an interaction with my other flags that is making it work, I don't know. My full call is: \usepackage[citestyle=authoryear,bibstyle=historian,backend=biber,isbn=false,language=american,sorting=nyt]{biblatex} – adam.baker Sep 26 '13 at 13:39
  • Might be the case, I could not get the line of code working, but if its solves you problem. – moewe Sep 26 '13 at 17:56
0

You can try using:

\ExecuteBibliographyOptions{dateabbrev=false}

or as an option:

\usepackage[dateabbrev=false,style=historian]{biblatex}
  • Thank you for responding. The dateabbrev parameter didn't have the desired effect, but it sent me to the right place in the docs, where I found the abbreviate parameter. – adam.baker Sep 25 '13 at 22:36
  • Great, somehow I forgot the question wasn't about dates... – Joseph Sep 26 '13 at 0:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.