7

I've just watched some YouTube videos given by ShareLatex. In the video I saw he constructed a Thesis in LaTeX. It is available here.

Now, I downloaded the whole package to see if it would run in my LaTeX editor (TexStudio), but when I ran/compiled it, everything seemed to be working, except the bibliography. It was supposed to be in the end, but nothing shows, and the citing just writes out the keyword of the .bib file.

I haven't touched anything at all, I just clicked Compile and "Build and View" when I opened the main document.

So yeah, why does it work on the ShareLatex website, but not on my computer in TexStudio. I'm obviously doing something wrong, but what ?

Thanks in advance.

7

The following worked for me. In TeXStudio, go to Options ---> Configure ---> Build and Choose. Check "Build and View". Then in the configuration (for example in the Quick Build) you need to have:

pdflatex (or XeLaTeX)
Biber
pdflatex (or XeLaTeX)
pdflatex (or XeLaTeX)


Default Viewer

The last one (Default Viewer) is not necessary. I think Biber is the key for having it run (at least in my case this was the only way to work).

After doing that (and given that you have chosen a place for your bibliography using the command \printbibliography), you must be able to get the result that you seek.

P.S. Another thing that is important to notice is that use \usepackage[utf8]{inputenc} instead of \usepackage[utf8x]{inputenc}. From what I have read you need to also include \usepackage[T1]{fontenc}.

I hope you will find a solution.

  • That seemed to do the trick :) Thank you very much. – Denver Dang Sep 25 '13 at 22:15
3

In TeXstudio, you can force it to run Biber on your file to rebuild the bibliography. Choose Tools -> Bibliography (the default hotkey is F11). Run this, then compile your document.

This way, you won't have to run PdfLaTeX repeatedly every time you compile. TeXstudio is supposed to automatically detect that you've changed your bibliography, and only then re-run biber, but apparently it sometimes gets confused.

0

A much simpler solution I just discovered is to add backend=biber to the \usepackage options for biblatex:

\usepackage[backend=biber]{biblatex}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.