6

I have just upgraded TeX Live to 2013 on Mac OS, and installed all the Cyrillic packages i could think of, but the hyphenation in Russian stopped working. Here is an example:

\documentclass[russian]{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{babel}
\begin{document}

Польский язык (język polski, polszczyzna) — язык поляков, относящийся к лехитской подгруппе западнославянской группы славянской ветви индоевропейской языковой семьи.

\end{document}

The log output:

This is pdfTeX, Version 3.1415926-2.5-1.40.14 (TeX Live 2013)
 \write18 enabled.
entering extended mode
(./hyphenation-test.tex
LaTeX2e <2011/06/27>
Babel <3.9f> and hyphenation patterns for 21 languages loaded.
(/usr/local/texlive/2013basic/texmf-dist/tex/latex/base/article.cls
Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
(/usr/local/texlive/2013basic/texmf-dist/tex/latex/base/size10.clo))
(/usr/local/texlive/2013basic/texmf-dist/tex/latex/base/inputenc.sty
(/usr/local/texlive/2013basic/texmf-dist/tex/latex/base/utf8.def
(/usr/local/texlive/2013basic/texmf-dist/tex/latex/base/t1enc.dfu)
(/usr/local/texlive/2013basic/texmf-dist/tex/latex/base/ot1enc.dfu)
(/usr/local/texlive/2013basic/texmf-dist/tex/latex/base/omsenc.dfu)))
(/usr/local/texlive/2013basic/texmf-dist/tex/latex/base/fontenc.sty
(/usr/local/texlive/2013basic/texmf-dist/tex/latex/base/t1enc.def))
(/usr/local/texlive/2013basic/texmf-dist/tex/generic/babel/babel.sty
(/usr/local/texlive/2013basic/texmf-dist/tex/generic/babel-russian/russianb.ldf
(/usr/local/texlive/2013basic/texmf-dist/tex/generic/babel/babel.def)

Package babel Warning: No hyphenation patterns were preloaded for
(babel)                the language `Russian' into the format.
(babel)                Please, configure your TeX system to add them and
(babel)                rebuild the format. Now I will use the patterns
(babel)                preloaded for english instead on input line 68.


Package babel Warning: No Cyrillic font encoding has been loaded so far.
(babel)                A font encoding should be declared before babel.
(babel)                Default `T2A' encoding will be loaded  on input line 111
.

(/usr/local/texlive/2013basic/texmf-dist/tex/latex/cyrillic/t2aenc.def
(/usr/local/texlive/2013basic/texmf-dist/tex/latex/base/t2aenc.dfu))))
(./hyphenation-test.aux
(/usr/local/texlive/2013basic/texmf-dist/tex/latex/cyrillic/t2acmr.fd))
Overfull \hbox (43.51624pt too wide) in paragraph at lines 9--10
\T2A/cmr/m/n/10 Í ÎÂıËÚÒÍÓÈ ÔÓ‰„ÛÔÔ Á‡Ô‡‰ÌÓÒ·‚ˇÌÒÍÓÈ „ÛÔÔ˚ Ò·‚ˇÌÒÍÓÈ ‚ÂÚ‚Ë
 Ë̉Ó‚ÓÔÂÈÒÍÓÈ
[1{/Volumes/Data/Users/alexey/Library/texlive/2013basic/texmf-var/fonts/map/pdf
tex/updmap/pdftex.map}] (./hyphenation-test.aux) )
(see the transcript file for additional information){/usr/local/texlive/2013bas
ic/texmf-dist/fonts/enc/dvips/cm-super/cm-super-t2a.enc}</usr/local/texlive/201
3basic/texmf-dist/fonts/type1/public/cm-super/sfrm1000.pfb>
Output written on hyphenation-test.pdf (1 page, 18449 bytes).
SyncTeX written on hyphenation-test.synctex.gz.
Transcript written on hyphenation-test.log.

Could you suggest me anything, how to fix it, please?

  • 1
    Welcome to TeX.SX! Can you add one word to the minimal example and show the contents of the log file you get? Please, remove all lines defining Unicode char ... (that are irrelevant). – egreg Sep 25 '13 at 23:19
  • @egreg: I have pasted the output from the console window, is it enough, or should i paste from the log file instead? – Alexey Sep 25 '13 at 23:38
  • The console window output is sufficient. You need to install hyphen-russian with TeX Live Utility. I suggest you to install the full MacTeX and forget about manually installing packages. – egreg Sep 25 '13 at 23:40
  • 1
    Try with sudo fmtutil-sys --all from a Terminal window (you'll need to supply an administrator password, your normal password should be good). – egreg Sep 25 '13 at 23:45
  • 1
    No, it's not possible. Maybe it can be a feature request. – egreg Sep 25 '13 at 23:50
10

If you have installed the hyphen-russian and the ruhyphen TeX Live packages, then it can be a problem of non updated formats. From a Terminal window run

sudo fmtutil-sys --all

and supply your password (assuming you're an administrator of your own machine) when requested. This will recreate all format files and should fix the issue.

A note: your example code won't run correctly; if you need to print well also Polish words, it's better to load also that language. You should also specify the T2A encoding as default.

\documentclass[a4paper]{article}
\usepackage[T1,T2A]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[polish,russian]{babel}

\begin{document}

Польский язык (\foreignlanguage{polish}{język polski, 
polszczyzna}) — язык поляков, относящийся к лехитской подгруппе 
западнославянской группы славянской ветви индоевропейской языковой семьи.

\end{document}

In this way the characters with the ogonek will be proper glyphs and not constructed ones.

| improve this answer | |
  • I've read somewhere that it is preferable to specify languages in \documentclass options instead of babel package options because this allows to omit them in babel options, and other packages can see which languages are used. Is it so? – Alexey Sep 30 '13 at 14:29
  • @Alexey It depends; if you declare only one language, then setting it as a global option (in \documentclass) may be better. If you have multiple languages, you have to be certain that the packages which benefit from these language options behave exactly like babel with respect to the order of the options. – egreg Sep 30 '13 at 14:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.