1

I'm not getting accentuation directly, even though I'm loading the package \usepackage[latin1]{inputenc}

My packages are:

\usepackage[brazil]{babel} % pacote portugues brasileiro
\usepackage[latin1]{inputenc} % pacote para acentuacao direta
\usepackage{amsmath,amsfonts,amssymb} % pacote matematico
\usepackage{graphicx} % pacote grafico
\usepackage{times} % fonte times
\usepackage{amscd}
\usepackage{epsfig}
\usepackage{amsxtra}
\usepackage{amsthm}
\usepackage[mathscr]{eucal}
\usepackage{indentfirst}
\usepackage{amstext}
\usepackage{textcomp}
\usepackage{verbatim}
\usepackage[all,cmtip]{xy}  % diagramas xy em LaTeX
\usepackage{subfigure}

is something wrong?

2
  • 3
    Hello, welcome to TeX.sx! We need to use a proper font encoding, so add \usepackage[T1]{fontenc} in the preamble as well. Hopefully this will fix things. :) Sep 26, 2013 at 16:28
  • 1
    Instead of inputenc, try with \usepackage{selinput} immediately followed by \SelectInputMappings{adieresis={ä},germandbls={ß}} (copy-paste from here). When you compile you should find in the log file a line telling you Package selinput Info: Encoding '...' selected. This should tell you with more precision what encoding your editor is using.
    – egreg
    Sep 26, 2013 at 20:17

1 Answer 1

2

Try this one, works quite good when using with Spanish:

\usepackage[portuguese]{babel}  
\usepackage[utf8]{inputenc}
4
  • Now why would you want to select the portuguese option if you want to typeset Spanish text? Choose spanish instead.
    – NVaughan
    Sep 27, 2013 at 1:45
  • I was just trying to say that this form has worked fine for me when writing in spanish, so if you just change it for portuguese instead of spanish you shouldn't have problems with Portuguese accentuation, I've already tried it. Sep 27, 2013 at 1:51
  • You'll probably get your hyphenation wrong, however.
    – NVaughan
    Sep 27, 2013 at 1:53
  • Then that would be a distribution problem. For fixing it he could try this. Sep 27, 2013 at 2:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .