15

I was trying to include a figure in LuaLatex, but got an error message of

!Package pdftex.def Error: File 'test-eps-converted-to.pdf' not found.

The same code run in pdfLaTex+MakeIndex+bibTex. Is there a way to fix this? Also, is there anyway to include a directory or file pathway that contains a white space (e.g., c:\my project\tex)?

\documentclass{article}    
\usepackage{graphicx,xcolor,colortbl}    
\usepackage{epstopdf,epsfig}    
\begin{document}    
\begin{figure}    
\includegraphics{test.eps}    
\end{figure}    
\end{document}

closed as unclear what you're asking by Keks Dose, barbara beeton, Werner, Mico, Gonzalo Medina Aug 14 '15 at 18:17

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    You could try to remove the eps extension from the \includegraphics command. – Nicolas Sep 26 '13 at 18:31
  • 2
    You have to call lualatex with the command line option --shell-escape – karlkoeller Sep 26 '13 at 18:43
  • 1
    Thanks. I tried removing the eps extension-now it shows "!LaTex Error: File 'test" not found". I put the .eps file in the same directory as the .tex file. Also, how can option --shell-escape be called for lualatex? – user36969 Sep 26 '13 at 19:11
  • 1
    From the command line lualatex --shell-escape myfile where myfile is the name of your .tex file. If you want to do that from your editor add --shell-escape to the command line of lualatex. – karlkoeller Sep 26 '13 at 19:24
  • 2
    @karlkoeller Can you confirm whether the issue is still present in MiKTeX? If not, it's better to close this question. – egreg Apr 10 '15 at 10:23

Browse other questions tagged or ask your own question.