2

I'm stuck here for hours trying to install fonts for TeXLive 2013. I did the same stuff as always:

  1. unzip to /usr/local/texlive/texmf-local
  2. run sudo mktexlsr
  3. then sudo updmap-sys --enable Map 5ch.map

After running the last line I'm getting message:

updmap: resetting $HOME value (was /Users/sFun) to root's actual home (/var/root).
updmap is using the following updmap.cfg files (in precedence order):
  /usr/local/texlive/2013/texmf-config/web2c/updmap.cfg
  /usr/local/texlive/2013/texmf-dist/web2c/updmap.cfg
updmap is using the following updmap.cfg file for writing changes:
  /usr/local/texlive/2013/texmf-config/web2c/updmap.cfg
dvips output dir: "/usr/local/texlive/2013/texmf-var/fonts/map/dvips/updmap"
pdftex output dir: "/usr/local/texlive/2013/texmf-var/fonts/map/pdftex/updmap"
dvipdfmx output dir: "/usr/local/texlive/2013/texmf-var/fonts/map/dvipdfmx/updmap"
pxdvi output dir: "/usr/local/texlive/2013/texmf-var/fonts/map/pxdvi/updmap"

ERROR:  The following map file(s) couldn't be found:
  5ch.map (in /usr/local/texlive/2013/texmf-config/web2c/updmap.cfg)

  Did you run mktexlsr?

  You can disable non-existent map entries using the option
    --syncwithtrees.

I also tried the same stuff for the texmf in the user library - same error message:(

  • 1
    It's better to append the line Map 5ch.map to the /usr/local/texlive/texmf-local/web2c/updmap.cfg file (create it if it doesn't exist yet). Then simply run sudo updmap-sys – egreg Sep 27 '13 at 17:30
  • Hm, I remove Map 5ch.map from the 2013/.../updmap.cfg and append as u said, then run updmap-sys: no error message, but font seems to be not there: aTeX Font Warning: Font shape `T1/5ch/m/n' undefined(Font) – SmartFun Sep 27 '13 at 17:42
  • That's a different problem: there should be a t15ch.fd file in the distribution or a .sty file with the necessary \DeclareFontShape commands – egreg Sep 27 '13 at 17:44
  • But I have t15ch.fd file in the distribution with \DeclareFontShape{T1}{5ch}{m}{n}{ <-> 5chr8t }{} – SmartFun Sep 27 '13 at 17:51
  • 1
    Thus either the file is not in the correct place or mktexlsr didn't succeed. – egreg Sep 27 '13 at 18:04
2

I finally installed my fonts. Somehow it does not work with updmap-sys. I just installed the fonts to my Library (~/Library/texmf) then create the updmap config file there (~/Library/texmf/web2c/updmap.cfg) and execute the updmap command.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.