25

I have read all the related questions and taken all the suggested steps (well, the ones that had anything to do with my situation since for example I am not using XeLaTeX). As far as I can see, this file ought to produce a pdf with one citation in it and a bibliography with that entry.

\documentclass{amsart}

\usepackage[]{biblatex}
\addbibresource{refs.bib}

\begin{document}
\cite{FefCF}

\printbibliography    
\end{document}

Instead it produces a pdf with the name FefCF printed in boldface and no bibliography.

I am using TeXworks and have run both BibTeX and pdfLaTex+MakeIndex+BibTeX repeatedly in many combinations.

To be clear, the reference FefCF is indeed in the file refs.bib (and has been used many time with BibTeX) and it is in the same folder as this file, namely C:/Users/Colin/Documents/TeX Files. I have also tried the full location name C:/Users/Colin/Documents/TeX Files/refs.bib to specify the bib resource. That makes no difference.

8
  • 7
    Welcome to TeX.SX! \usepackage[]{biblatex} is not a proper call to biblatex especially if you want to run it with BibTeX. Try \usepackage[style=authoryear, backend=bibtex]{biblatex} instead; or install biber and try \usepackage[style=authoryear, backend=biber]{biblatex} (then, of course, you will have to run pdlfatex + biber + pdflatex + pdflatex).
    – moewe
    Sep 28, 2013 at 15:34
  • @moewe Thanks. Biber is installed and I have tried this with biber and bibtex. TeXworks does not give me an option of running biber the way it does bibtex. Anyway no combination of pdflatex and bibtex has worked for me yet. Sep 28, 2013 at 15:43
  • 1
    Mhhhh. What is the (.log) output of the LaTeX and BibTeX/biber runs respectively? Note that if at all the exact document you posted only works with biber (I might have replied glibly when I said your call was not proper as it should work with biber). For biber in TeXworks see How to automate using biber in MiKTeX-TeXworks and Dummies Guide to Biber
    – moewe
    Sep 28, 2013 at 15:46
  • 1
    I'd also consider using the wonderful arara tool to automate the process, as shown in How do I set up my LaTeX document to enable me to cite from my BibTeX bibliography?
    – cmhughes
    Sep 28, 2013 at 15:52
  • 2
    Having read the comments in the question linked above one might pessimistically suspect it will be quite a long run indeed.
    – moewe
    Sep 28, 2013 at 16:54

2 Answers 2

10

The main hurdles with biblatex/biber are:

  1. You are not calling biber at all but bibtex (check the .blg file if it starts with "biber" or "bibtex").
  2. biber fails due to a problem with the cache files. Run biber --cache on the command line and delete the folder you get as output.
  3. biber fails due to an error in your bib file: Check the blg file.
3
  • Is 1 a problem when I have set backend=bibtex? Sep 28, 2013 at 17:43
  • @ColinMcLarty It should not be at all, except, of course, for cases in which biber is necessary. Remember to remove all auxiliary files though.
    – moewe
    Sep 28, 2013 at 19:25
  • @colinMcLarty: 1 + 2 are biber specific. Sep 28, 2013 at 21:05
9

Biblatex now uses Biber as default backend. It used to use BibTeX before.

Here are the steps to make bibliography display for your LaTeX document:

Install Biber

On Ubuntu:

sudo apt-get install biber

Using biber as backend

\usepackage{biblatex}
OR,
\usepackage[backend=biber]{biblatex}

Then compilation should be done with the following commands (assuming your LaTeX file name is myfile.tex):

pdflatex myfile
biber myfile
pdflatex myfile

Using bibtex as backend

\usepackage[backend=bibtex]{biblatex}

Then you have to run the following commands to compile the file (myfile.tex):

pdflatex myfile
bibtex myfile
pdflatex myfile

Now, you should be able to see bibliography page when you open your pdf file (myfile.pdf in this example).

Reference: http://www.latex-community.org/forum/viewtopic.php?f=50&t=22023#p74103

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.