1

I am rather a beginner to LaTeX while I have already written quite some nice articles with it. Yet I am inquiring problems to get a particular package to run on Windows 7, namely itrans.

I am using MikTex 2.9 and Texmaker on Windows 7 (64-bit) to produce LaTeX documents. Now I want to use Tamil typesetting via the itrans package. However, as you have mentioned in the below threads MikTex does not install the package automatically on Windows. I tried to follow your steps but receive the following error messages when trying to run your below code in Texmaker via 'XeLaTex' or 'LaTeX'.

\documentclass[11pt]{article}
\usepackage[preprocess]{itrans}

\newfont{\tmlb}{wntml12}
\newfont{\tmls}{wntml10}
\newfont{\devnf}{dvng10 scaled \magstep1}
#tamilifm=wntml.ifm
#tamilfont=\tmlb
#hindiifm=dvng.ifm
#hindifont=\devnf

\begin{document}
Thank you!
{#tamil na^nRi #endtamil}
{#hindi dhanyavaad #endhindi}
\end{document}

Log File:

LOG FILE :
This is XeTeX, Version 3.1415926-2.4-0.9998 (MiKTeX 2.9 64-bit) (preloaded format=xelatex 2013.9.22) 30 SEP 2013 08:51
entering extended mode
**Tamil.tex
("C:\Users\Prasath\Documents\LaTeX course\Tamil.tex"
LaTeX2e <2011/06/27>
Babel <v3.8m> and hyphenation patterns for english, afrikaans, ancientgreek, ar
abic, armenian, assamese, basque, bengali, bokmal, bulgarian, catalan, coptic,
croatian, czech, danish, dutch, esperanto, estonian, farsi, finnish, french, ga
lician, german, german-x-2012-05-30, greek, gujarati, hindi, hungarian, iceland
ic, indonesian, interlingua, irish, italian, kannada, kurmanji, latin, latvian,
lithuanian, malayalam, marathi, mongolian, mongolianlmc, monogreek, ngerman, n
german-x-2012-05-30, nynorsk, oriya, panjabi, pinyin, polish, portuguese, roman
ian, russian, sanskrit, serbian, slovak, slovenian, spanish, swedish, swissgerm
an, tamil, telugu, turkish, turkmen, ukenglish, ukrainian, uppersorbian, usengl
ishmax, welsh, loaded.
("C:\Program Files (x86)\MikTex 2.9\tex\latex\base\article.cls"
Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
("C:\Program Files (x86)\MikTex 2.9\tex\latex\base\size11.clo"
File: size11.clo 2007/10/19 v1.4h Standard LaTeX file (size option)
Requested font "cmr10" at 10.95pt
-> cmr10
)
\c@part=\count80
\c@section=\count81
\c@subsection=\count82
\c@subsubsection=\count83
\c@paragraph=\count84
\c@subparagraph=\count85
\c@figure=\count86
\c@table=\count87
\abovecaptionskip=\skip41
\belowcaptionskip=\skip42
\bibindent=\dimen102
)
("C:\Program Files (x86)\MikTex 2.9\tex\latex\itrans\itrans.sty"
File: itrans.sty 1998/6/12
("C:\Program Files (x86)\MikTex 2.9\tex\latex\itrans\idevn.tex"
Requested font "cmr6" scaled 1000
-> cmr6
Requested font "cmr8" scaled 1000
-> cmr8
Requested font "cmr9" scaled 1000
-> cmr9
))
Requested font "wntml12" scaled 1000
-> wntml12
Requested font "wntml10" scaled 1000
-> wntml10
Requested font "dvng10" scaled 1200
-> dvng10
! You can't use `macro parameter character #' in vertical mode.
l.7 #
tamilifm=wntml.ifm
Sorry, but I'm not programmed to handle this case;
I'll just pretend that you didn't ask for it.
If you're in the wrong mode, you might be able to
return to the right one by typing `I}' or `I$' or `I\par'.
! LaTeX Error: Missing \begin{document}.
See the LaTeX manual or LaTeX Companion for explanation.
Type H <return> for immediate help.
...
l.7 #t
amilifm=wntml.ifm
You're in trouble here. Try typing <return> to proceed.
If that doesn't work, type X <return> to quit.
! You can't use `macro parameter character #' in horizontal mode.
l.8 #
tamilfont=\tmlb
Sorry, but I'm not programmed to handle this case;
I'll just pretend that you didn't ask for it.
If you're in the wrong mode, you might be able to
return to the right one by typing `I}' or `I$' or `I\par'.
! You can't use `macro parameter character #' in horizontal mode.
l.9 #
hindiifm=dvng.ifm
Sorry, but I'm not programmed to handle this case;
I'll just pretend that you didn't ask for it.
If you're in the wrong mode, you might be able to
return to the right one by typing `I}' or `I$' or `I\par'.
Missing character: There is no i in font wntml12!
Missing character: There is no i in font wntml12!
Missing character: There is no i in font wntml12!
Missing character: There is no f in font wntml12!
Missing character: There is no v in font wntml12!
Missing character: There is no g in font wntml12!
Missing character: There is no . in font wntml12!
Missing character: There is no i in font wntml12!
Missing character: There is no f in font wntml12!
! You can't use `macro parameter character #' in horizontal mode.
l.10 #
hindifont=\devnf
Sorry, but I'm not programmed to handle this case;
I'll just pretend that you didn't ask for it.
If you're in the wrong mode, you might be able to
return to the right one by typing `I}' or `I$' or `I\par'.
Missing character: There is no i in font wntml12!
Missing character: There is no i in font wntml12!
Missing character: There is no f in font wntml12!
Missing character: There is no o in font wntml12!
("C:\Users\Prasath\Documents\LaTeX course\Tamil.aux")
LaTeX Font Info: Checking defaults for OML/cmm/m/it on input line 12.
LaTeX Font Info: ... okay on input line 12.
LaTeX Font Info: Checking defaults for T1/cmr/m/n on input line 12.
LaTeX Font Info: ... okay on input line 12.
LaTeX Font Info: Checking defaults for OT1/cmr/m/n on input line 12.
LaTeX Font Info: ... okay on input line 12.
LaTeX Font Info: Checking defaults for OMS/cmsy/m/n on input line 12.
LaTeX Font Info: ... okay on input line 12.
LaTeX Font Info: Checking defaults for OMX/cmex/m/n on input line 12.
LaTeX Font Info: ... okay on input line 12.
LaTeX Font Info: Checking defaults for U/cmr/m/n on input line 12.
LaTeX Font Info: ... okay on input line 12.
! You can't use `macro parameter character #' in horizontal mode.
l.14 {#
tamil na^nRi #endtamil}
Sorry, but I'm not programmed to handle this case;
I'll just pretend that you didn't ask for it.
If you're in the wrong mode, you might be able to
return to the right one by typing `I}' or `I$' or `I\par'.
! Missing $ inserted.
<inserted text>
$
l.14 {#tamil na^
nRi #endtamil}
I've inserted a begin-math/end-math symbol since I think
you left one out. Proceed, with fingers crossed.
Requested font "cmmi10" at 10.95pt
-> cmmi10
Requested font "cmmi8" at 8.0pt
-> cmmi8
Requested font "cmmi6" at 6.0pt
-> cmmi6
Requested font "cmsy10" at 10.95pt
-> cmsy10
Requested font "cmsy8" at 8.0pt
-> cmsy8
Requested font "cmsy6" at 6.0pt
-> cmsy6
LaTeX Font Info: External font `cmex10' loaded for size
(Font) <10.95> on input line 14.
LaTeX Font Info: External font `cmex10' loaded for size
(Font) <8> on input line 14.
LaTeX Font Info: External font `cmex10' loaded for size
(Font) <6> on input line 14.
! You can't use `macro parameter character #' in math mode.
l.14 {#tamil na^nRi #
endtamil}
Sorry, but I'm not programmed to handle this case;
I'll just pretend that you didn't ask for it.
If you're in the wrong mode, you might be able to
return to the right one by typing `I}' or `I$' or `I\par'.
! Extra }, or forgotten $.
l.14 {#tamil na^nRi #endtamil}
I've deleted a group-closing symbol because it seems to be
spurious, as in `$x}$'. But perhaps the } is legitimate and
you forgot something else, as in `\hbox{$x}'. In such cases
the way to recover is to insert both the forgotten and the
deleted material, e.g., by typing `I$}'.
! You can't use `macro parameter character #' in math mode.
l.15 {#
hindi dhanyavaad #endhindi}
Sorry, but I'm not programmed to handle this case;
I'll just pretend that you didn't ask for it.
If you're in the wrong mode, you might be able to
return to the right one by typing `I}' or `I$' or `I\par'.
! You can't use `macro parameter character #' in math mode.
l.15 {#hindi dhanyavaad #
endhindi}
Sorry, but I'm not programmed to handle this case;
I'll just pretend that you didn't ask for it.
If you're in the wrong mode, you might be able to
return to the right one by typing `I}' or `I$' or `I\par'.
! Missing $ inserted.
<inserted text>
$
l.16 \end{document}
I've inserted a begin-math/end-math symbol since I think
you left one out. Proceed, with fingers crossed.
[1
] ("C:\Users\Prasath\Documents\LaTeX course\Tamil.aux") )
(\end occurred inside a group at level 1)
### simple group (level 1) entered at line 14 ({)
### bottom level
Here is how much of TeX's memory you used:
326 strings out of 429035
3275 string characters out of 3166907
51246 words of memory out of 3000000
3646 multiletter control sequences out of 15000+200000
7707 words of font info for 27 fonts, out of 3000000 for 9000
912 hyphenation exceptions out of 8191
21i,4n,19p,167b,111s stack positions out of 5000i,500n,10000p,200000b,50000s
Output written on Tamil.pdf (1 page).

I am not quite sure how to approach these error messages. So far I followed your instructions from another thread:

Typesetting Tamil is possible with the itrans pakcage, but it's not packaged properly in MikTeX. You will need to install it manually. Download itrans53-win32.zip from CTAN. After unzipping the contents (say C:\itrans53), assuming being your local TEXMF tree,

Move the contents of the lib folder into <texmf>\tex\latex\itrans
Move the contents of the fonts folder into the appropriate locations, i.e.
    *.mf in <texmf>\fonts\source\itrans
    *.afm in <texmf>\fonts\afm\itrans
    *.tfm in <texmf>\fonts\tfm\itrans
    *.pfb, *.pfa, *.pfm in <texmf>\fonts\type1\itrans
    *.ttf in <texmf>\fonts\truetype\itrans
Refresh the file name database (e.g. via MikTeX Options/Settings)

Then try out the minimal example I gave in my answer to this related question. You would need to evoke itrans.exe in the itrans53\bin folder. (However I'm not sure if it works in 64-bit Windows.)

Do you have other suggestions what I can do? Or is there a how-to for Dummies available anywhere?

Tamil Tex in windows

LaTeX/XeTeX setup Tamil/Indic languages

http://latex-my.blogspot.ch/2010/08/tamil-and-hindi-support-in-latex.html

  • 1
    Welcome to TeX.SX! Have a look to our starter guide to familiarize yourself further with the habits of this website. – Ludovic C. Sep 30 '13 at 7:55
  • I read through the starter guide and will follow the guidelines of course. Do you have any suggestion how I can find a solution to my problem? Is the formulation of the problem inconcise? – soosap Sep 30 '13 at 8:34
  • Try to get a question title a little more catchy (you don't need to specify all your settings in the title. That might help to get the attention on your question. – Ludovic C. Sep 30 '13 at 8:44
  • I'm really unhappy that someone down-voted the question since there's no reason to do so. On the other hand, the problem seems to be quite specific so I'm not sure whether it gets an answer quite soon... – yo' Sep 30 '13 at 8:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.