New to Stack Exchange, and using TeX for a week.. Trying to make glossaries work for a larger document, but this even fails with the first example document provided by the glossaries package.. I have: TeXStudio 2.5.2 MikTeX 2.9, Perl Strawberry latest version 32-bit installed and even checked if the PATH was added correctly (after scavanging other answers to posts) (in commandpromt perl -v returns the version.. I checked all the packages needed for the glossaries package. I added a custom user command to add the makeglossaries command available for running. After a first pdfLaTeX compile and run, I get an error when running makeglossaries.

The error message I am getting is:

Process started: "C:/LaTeX/scripts/glossaries/makeglossaries.bat"
makeglossaries: Need exactly one file argument. Use `makeglossaries --help' for help.
Process exited with error(s)

Please help me solve this, I've looked everywhere and long but nothing can be found on this error. The glossary is not created in the pdf, but the first run does create the 1 page document correctly.

The .tex is minimalgls.tex (provided by package):


 \usepackage{glossaries} % acronym will go in main glossary
 %\usepackage[acronym]{glossaries} % make a separate list of acronyms

description={a sample entry}}

acronyms]{aca}{aca}{a contrived acronym}

A \gls{sample} entry and \gls{aca}. Second use: \gls{aca}.

Plurals: \glspl{sample}. Reset acronym\glsreset{aca}.
First use: \glspl{aca}. Second use: \glspl{aca}.

  • thanks for the edits @moewe, how do I create the grey boxes for subsequent questions etc? Sep 30, 2013 at 15:30
  • Have a look at Markdown help or at the changed code of your question.
    – moewe
    Sep 30, 2013 at 15:32
  • It sounds like there's a problem with the way that TeXstudio is calling makeglossaries. I don't use TeXstudio, but try How to configure texstudio to use glossaries. How did you add the custom command? Sep 30, 2013 at 16:58
  • @Nicola Talbot I have added a user command (options->configure TeXstudio-> tab Build) where you can enter a command by typing a name and a path.. I have tried "C:/LaTeX/miktex/bin/x64/makeglossaries.exe" which is where I found the .exe file, but as the manual said to load the .bat file, I have also tried "C:/LaTeX/scripts/glossaries/makeglossaries.bat".. Both return me the same error message. Oct 1, 2013 at 8:21
  • @RoelandVisser Did you add ` %` (space followed by percent sign) after the path? (I don't know if the percent sign needs to be in double-quotes. It may need it if you have spaces in your path names.) Oct 1, 2013 at 9:10

1 Answer 1


I had the same trouble with TeXstudio on Windows and did not find out to solve it. I finally download Texmaker and follow the step describe in the wiki.


In Texmaker, go to User -> User Commands -> Edit User Commands.
Chose command 1
Menuitem = makeglossaries
Command = makeglossaries %
Now push Alt+Shift+F1 and then ->F1

You have to download and install Xindy which have Perl included (Perl is necessary to run the makeglossaries script).

Edit: The same solution could be used with TexStudio using the following instruction:

option -> configure TeXstudio ...
in Build add an User Command and fill it as the image bellow.
Now push Alt+Shift+F1 (or Tools -> User -> makeglossaries)

enter image description here

  • Xindy could be find on fys.ku.dk/~tlinnet/xindy-win.exe
    – R.Falque
    Oct 18, 2013 at 2:58
  • Read How to use Xindy with MiKTeX?, please!
    – Speravir
    Feb 5, 2014 at 2:29
  • I was just trying to help, but do you mean that this method does not work?
    – R.Falque
    Feb 6, 2014 at 0:10
  • Your method should be better, sure ... but is complicated. We are just different users and I just want it to work. the method I used is working and solve my problem in a few minutes.
    – R.Falque
    Feb 6, 2014 at 0:31
  • Your answer is wrong related to the question, but my point was simply, that you recommend a installation of absolutely obsolete versions. Read the answers of linked questions and also the updated Wiki entry. (Oh sorry deleted and rewritten while you wrote your own comment.)
    – Speravir
    Feb 6, 2014 at 0:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.