3

I am very new to LaTeX and the world of programming in general, and I am writing my M.A. thesis using LaTeX. The Chicago style is required for my thesis, so I got the biblatex-chicago package. this is an outline of my document:

\documentclass[12pt]{article}

\usepackage[style=chicago-authordate]{biblatex}

\bibliography{refs}

\begin{document}

--then the body of the paper with some citations and the \printbibliography command--

\end{document}

When I run it through BibTeX, I get the following errors:

This is BibTeX, Version 0.99d (TeX Live 2013)

The top-level auxiliary file: Bodhi Ch. 1.aux

I found no \citation commands---while reading file Bodhi Ch. 1.aux

I found no \bibdata command---while reading file Bodhi Ch. 1.aux

I found no \bibstyle command---while reading file Bodhi Ch. 1.aux

(There were 3 error messages)

Also, the bibliography and the citations don't come out, presumably because BibTeX was not able to process the file.

The name of my project is "Bodhi Ch. 1"

Anyone know what this is about?

  • 1
    You Have to compile the bibliography with biber not bibtex. To use bibtex you have to specify backend=bibtex as one of the options of biblatex. Also remember to include the extension bib for the bibliography file. – Guido Oct 4 '13 at 9:58
  • 1
    @Guido The part with the .bib extension for the bibliography file depends on the way you include it. If you include it using the \bibliography command (as the questioner does) you must not use it. If you use the \addbibresource command, you need it. – Benedikt Bauer Oct 4 '13 at 11:13
  • @BenediktBauer The .bib is optional with \bibliography. According to the biblatex manual \bibliography is maintained for legacy document, but it is otherwise deprecated – Guido Oct 5 '13 at 2:52
  • Thanks for your help guys, I got it up and running by putting [backend=bibtex] as an option for the \usepackage{biblatex-chicago} command. By the way, what are the pros and cons of using biber vs. bibtex as a compiler? – Paul Oct 10 '13 at 9:42
2

There are a couple of things here:

  1. You are using bibtex instead of what it seems you want to use, biblatex. For this, you first need to change the path to the executable file. I cannot tell you how to do this because I do not know what type of editor you are using, but for example, if using TeXnicCenter it's just a matter of changing this on the profile settings.

  2. If you actually want to use bibtex (which I personally prefer... but many folks around here just love biblatex) you need to:

    2.1 Instead of \usepackage[style=chicago-authordate]{biblatex} change it for \usepackage{natbib}

    2.2 You need to create a .bib file which contains the bibliography entries.

    2.3 In order to not get the warnings, you actually need to \cite any of the authors of your .bib file (thus eliminating the problem of not finding \citation commands) , and of course this file should not be empty (thus eliminating the problem of not finding \bibdata and finally you have to set a \bibliographystyle, that since you are using the natbib package mentioned at the beginning, you'll get the options to choose the style you want.

    2.3.1 As it seems the style you need is Chicago, this could be implemented by \bibliographystyle{chicagoa}

  3. Now, if you want to use biblatex it is usually recommended to go along with biber. This could be a good starting point: Setting up biber as a default biblatex backend in the configuration file

  • I am using TeXShop for Mac. There is a pull-down menu for which program to run the .tex file through, and here there are options for LaTeX, XeLaTeX, and BibTeX, but no option for BibLaTeX. This is why I used BibTeX to process it. How would I run it through BibLaTeX instead? Thanks for your help! – Paul Oct 7 '13 at 10:48
  • Hi, thanks for your help, I got it up and running. – Paul Oct 10 '13 at 9:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.