3

I'm using biblatex for my bibliography with the author-year style. I'd like to have only one author when using \parencite, e.g. (Anderson et al. 2009). But I want to show all the names in the Bibliography.

I tried the maxnames=1 option, but it works for both. How can I do?

This are the option for my biblatex:

\usepackage[style=authoryear-comp,sortcites=true,firstinits=true,%
            doi=false,url=false,isbn=false, hyperref]{biblatex}
3

You have to use the option maxcitenames=1 and not maxnames=1.

maxcitenames affects only the citations in the document body, maxbibnames affects only the bibliography and maxnames affects both.

So, load biblatex in this way:

\usepackage[style=authoryear-comp,maxcitenames=1,sortcites=true,%
            firstinits=true,doi=false,url=false,isbn=false,%
            hyperref]{biblatex}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.