3

After an updated of AUCTeX (to 11.87) the solution that worked wonderful from this answer stopped working. In particular, I got the following error:

reftex-reference: Wrong number of arguments: (lambda (label def-fmt) (format "\\cref{%s}" label)), 3

As a side remark, for this solution to be usable I had to add (setq reftex-ref-macro-prompt nil), otherwise an annoying intermediate menu poped-up. I guess it has to do with the update as well, but it is not related to the problem I'm considering in this question.

In turn, I found this answer (of @giordano) which solved the issue (once I disabled the previous hack). However, there is one problem left - when I try to refer to an equation, namely, M-x reftex-reference RET e up/down RET, the system inserts \eqref{label} and not \cref{label}. Is there a way to fix this? Any idea?

1
  • I'm not really familiar with RefTeX code, but I suspect that some functions (perhaps reftex-reference?) should be redefined. I suggest you to report this to AUCTeX mailing list.
    – giordano
    Oct 6, 2013 at 10:10

1 Answer 1

1

This was a bug inside RefTeX, fixed in Emacs trunk with commit

Improve reftex-format-special

  • lisp/textmodes/reftex-ref.el (reftex-format-special): Make it work also for AMS Math's \eqref macro.

See it in git or bazaar.

Unfortunately, this will be available in the release following the yet-to-be-released Emacs 24.4.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .